Dahdi only starts when dahdi_hardware command is run

I’m using Digium Wildcard TDM800P 8-port analog card (rev 11)
DAHDI Version: 2.11.0 Echo Canceller: HWEC
Asterisk 1.8.28-cert5 from source
On an x86_64 running Linux on 2016-02-10 (Debian stable).

After a reboot
~$ lsmod | grep dahdi
dahdi_vpmadt032_loader 184915 0
dahdi_voicebus 53442 2 wctdm24xxp,dahdi_vpmadt032_loader
dahdi 212264 2 wctdm24xxp,dahdi_voicebus
crc_ccitt 12347 2 wctdm24xxp,dahdi
Looks like dahdi is loaded.

At the asterisk command line no dahdi commands are available.
When I run
CLI> module load chan_dahdi.so
I get
Unable to load module chan_dahdi.so
Command ‘module load chan_dahdi.so’ failed.
[Feb 24 16:36:23] WARNING[762]: chan_dahdi.c:4380 dahdi_open: Unable to specify channel 1: No such device or address
[Feb 24 16:36:23] ERROR[762]: chan_dahdi.c:12420 mkintf: Unable to open channel 1: No such device or address
here = 0, tmp->channel = 1, channel = 1
[Feb 24 16:36:23] ERROR[762]: chan_dahdi.c:17023 build_channels: Unable to register channel ‘1’

Here’s the strange part. If I run:
$ sudo dahdi_hardware
pci:0000:04:00.0 wctdm24xxp+ d161:0800 Wildcard TDM800P

I can now “module load chan_dahdi” in asterisk!

Did I miss something somewhere?

I have seems many dahdi’s issue lately, the system is complaining about channel 1 . Check your configuration on chan_dahdi.conf, I’m not sure if there is an issue with Latest Version 2.11.0, It could be possible that you will need to downgrade dahdi check the following threads