Dahdi_dummy not loading on XEN

Hi everybody!

Hope someone can help me to sort this out:
I’ve a fresh installation of debian lenny with kernel 2.6.26-1-xen-686 (it is actually a virtual box DomU running on top of another lenny) and when trying to load the dahdi_dummy module i get this

[quote][36696.446598] dahdi_dummy: Unknown symbol rtc_register
[36696.446742] dahdi_dummy: Unknown symbol rtc_unregister
[36696.446742] dahdi_dummy: Unknown symbol rtc_control
FATAL: Error inserting dahdi_dummy (/lib/modules/2.6.26-1-xen-686/dahdi/dahdi_dummy.ko): Unknown symbol in module, or unknown parameter (see dmesg)[/quote]

Dahdi is already loaded and stays up without returning any error but dummy doesn’t want to be loaded therefore i’m not able to receive calls on my asterisk. All calls are dropped playing the “no service” tone.

I googled for it and seems that this is a known problem but I wasn’t able to find a solution.

Another useful info:
Module Size Used by
dahdi 183368 0
crc_ccitt 2848 1 dahdi

I tried to compile both with dahdi 2.0 and 2.1 rc4 (same error returned), the headers downloaded to compile dahdi are the correct ones (linux-headers-2.6.26-1-xen-686).

Thanks in advance for your help!

look for asterisk or rtc.ko on maillists xen-users and xen-devel, it’s probably the same problem.

Hi bodek,

thanks for the hint. I’m currently looking into there but it’s quite a pain to set up a fully functional asterisk-debian box on xen…
Btw I at least fixed the problem of the incoming calls: it was stupidly the “allow anonymous SIP calls” set to “No” and somehow every call I receive is seen by Asterisk as “Anonymous peer” even if it has an actual number displayed on the client.