Softphone error 'Account failed to enable' (SIP error 408)


#1

Hi,
This is my first time with asterisk so please bear with me.

I’m taking the Asterisk Essentials video course but got stuck. What I’m trying to do is set up a softphone to connect to the asterisk server. The one used in the video is x-lite and I downloaded and installed it and configured it. But it fails to enable.
The linux server has IP: 192.168.7.53. I pinged from my PC (192.168.7.59) the server and viceversa and got replies on both.
There is a sonic wall in our network and I created access routes from my IP to the asterisk server and back with SIP as the Service. Did I miss something?

Thanks


#2

408 is “request timed out”. I suspect that is generated internally within the phone, because something is eating either the request or the response. Running sip debugging on Asterisk will tell you whether it is ever seeing the request.


#3

The server never gets the request. So I’m thinking that the problem may be the firewall. Can you think of something else?


#4

What’s your network address? Seems like you’re both on the same subnet, so any firewall blocking this would be either asterisk server firewall or a firewall at your computer. I’m not sure what distribution are you using, but under redhat based ones a “/etc/init.d/iptables stop” command should disable the firewall.


#5

SGM thanks for your help. That was the problem. At least part of it. It opened the connection between the softphone and the server.
Then I ran into another problem but was easily solved.

Thanks again