Away message/voicemail woes


#1

Ok, we attempted to upgrade to Asterisk 1.0.9. We copied over all of the old configs (and commented/noloaded out unbuilt modules, namely chan_sccp.so for our Cisco phones), made all of the server things function (sshd, dhcpd, etc), and started the asterisk service. All seemed to go well until we checked our voicemail messages. We then received the following errors:

Oct 11 19:56:52 WARNING[6573]: format_wav.c:140 check_header: Not a wav file 49
Oct 11 19:56:52 WARNING[6573]: file.c:418 ast_filehelper: Unable to open fd on /var/spool/asterisk/voicemail/default/5933/unavail.wav
Oct 11 19:56:52 WARNING[6573]: file.c:804 ast_streamfile: Unable to open /var/spool/asterisk/voicemail/default/5933/unavail (format ulaw): No such file or directory

I’ve tried editing the /etc/asterisk/voicemail.conf file to say “format=wav49”, then “format=wav”, and nothing. I also tried changing the permissions to 777, and nothing. Any ideas?


#2

Ok, so it seems that Asterisk decided it didn’t want to play nice w/wav files anymore. We ended up converting to GSM to make it work again.