Problem with voicemail "No audio available on SIP/MY NU

Hi all!

I recently installed asterisk v. 1.4 after reinstalling my server with fedora core 5 (from FC 3 with asterisk 1.2).

Everything worked fine with asterisk installation and I copied over my .conf files from old asterisk version. The system is running fine - I can receive and make calls via my IP-phone provider which is registered in sip.conf.

The problem with this new verision of asterisk is that my voicemail no longer works. It works if I call it from my computer with “x-lite” but not if I call from a regular phone.

If I run asterisk -r i get this output when trying to leave a VM-message:

– Playing ‘beep’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/2210/tmp/7aYm4J format: wav49, 0x82ac598
– x=1, open writing: /var/spool/asterisk/voicemail/default/2210/tmp/7aYm4J format: gsm, 0x82aa930
– x=2, open writing: /var/spool/asterisk/voicemail/default/2210/tmp/7aYm4J format: wav, 0x82aac00
[Jan 7 15:08:34] WARNING[19276]: app.c:595 __ast_play_and_record: No audio available on SIP/0855802555-082a1590??
– User hung up
== Spawn extension (teleman-carl-in, 9, 2) exited non-zero on ‘SIP/0855802555-082a1590’

Then the asterisk server hangs up and i can’t leave a message! This used to work and I’m also using the same conf-file as before. Does anybody know what is wrong?

Help is much appreciated!


Which codecs are you using. Are you using G.729. If so make sure that you have a version that works with 1.4.


Thank you for your reply. This is the general section of my sip.conf:
I guess the codecs is the ulaw and alaw.

port=5060 ;port to bind to
bindaddr= ;Address to bind SIP channel to
context=inbound-sip ;Default context for incoming calls
;tos=0x04 ;reliability

The strange thing is that it’s possible to record a voicemail if i call my extension from another sip phone in my local network!

How can I see if my version is compatible with 1.4?

Thanks again

Hi again

Now I’ve tried recompiling and changing country settings in various config files but I just can’t get this to work. Anyone else who has experienced this problem?


the warning message comes in app.c, soo i think its your self made application that enables you to use voicemail.

well the first thing you need to know the 1.4 code has omitted few functions and changes that were made in 1.2, soo you might need to review your code of your application i.e “app.c”

btw: i am assuming that app.c is your own application, cause i never seen this file in the default asterisk package. :exclamation:

Thanks for your reply, it’s much appreciated!

Actually I have just downloaded and installed the regular asterisk and zaptel tarballs.

Then I just ran ./configure
make clean
make install

I got no errors and everything seems to be working fine except the voicemail. Could it be fedora core 5 that is the problem? I ran FC 3 before I reinstalled everything.

Thanks again!

EDIT: I am using asterisk without any digium hardware for now, so I’m only using SIP.

Hi all,

I got tired of not being able to fix the problem so I compiled asterisk 1.2.14 and zaptel 1.2.12 and now everything is working fine again. I don’t have an answer to what was wrong before. If anyone has an idea on how to solve it, please post it here anyway to help someone in the future!


Hi calleg,

got the same error here here.
Just to let you know.

I’m running a x86_64 machine and there have been some issues with 32bit drivers, maybe this is a incompatibility somewhere in the audio codecs.

If I get around it, I’ll let you know.