Asterisk Home with VMware - how do I sync clock on boot?

I am running Asterisk Home with Virtual Workstation but every time I boot the VM server the clock and date is out of sync with the hardware/system clock. Does anyone know how to set it up so it boots and sets the clock correctly from the server?

Thanks! … faqid=1318

I posted the below to your email thread query. Note - the ntp info bubba pointed to is useful, I have found that the changes below make the biggest difference:

Take a look at /etc/grub.conf and on the line(s) that look something like:

kernel /vmlinuz-2.6.9-34.0.1.EL ro root=LABEL=/

add clock=pit so that it looks something like:

kernel /vmlinuz-2.6.9-34.0.1.EL ro root=LABEL=/ clock=pit

You will also want to install VMWare Tools and then in your “.vmx” vmware file you will want to set:

tools.synctime = “TRUE”

That line will not be there (I don’t think) if you have not installed the VMWare Tools.

Beyond that - if you still have problems, turn off the NTP daemon.


Thanks the info guys. I overlooked the maiing list, sorry. Anyway, I made the changes and installed VMware tools. And it does now sync with the system clock but is one hour behind, which I presume is time zone related. However I checked the clock config (/etc/sysconfig/clock) and the timezone was correct. UTC was set to false and I changed this to true but still not synching the hour correctly.

Any thoughts?

it’s the timezone one way or another if it is syncing. Sounds like a daylight savings issue or soemthing.