Asterisk GUI 2.0 problem

Hello All,

Doing a new server install of F10 with Asterisk from Fedora repos.
Install Asterisk GUI svn 2.0-r4991
When trying to log into the Web GUI I get ;
“The GUI does not have necessary privileges!
Please check the manager permissions for the user!”

I have set all the possible parameters ,including ‘originate’ for 1.6 Ast.
I also read were installing the asterisk-dahdi package cured this (from an earlier post) for GUI2.0 . I did install the dahdi package and still the same results.
In the Asterisk CLI it does show this adim user with what appears to be correct permissions ( of everything)
I even created a second admin user with same results.
I do not see any errors in the httpd errors, as well as asterisk session logs,on the server?


I thought I should mention as well,after installing Asterisk GUI 2.0 I was getting the “http 404 not found” error. After searching the forums here I did find a resolve for this from an earlier post,by doing an ’ remove the /usr/share/asterisk/‘http-static’ dir,then doing an ’ ln -s /var/lib/asterisk/staic-http/ /usr/share/asterisk/ . This made the Asterisk GUI available then.
Also when doing an ‘check menuconfig’,it returns "everything looks OK"
When doing an ’ http show status’ from the asterisk CLI everything looks correct.
I am guessing by having to remove the one dir and then symlinking,something is not correct,but I do not know how to troubleshoot this?
I have done a couple successful installs of Asterisk GUI 1.0 without any problems way back…

Any ideas?

Thank You,

Did you modify the manager and http.conf files? There in the /etc/asterisk/ directory… Here is what mine look like…
displaysystemname = yes
enabled = yes
webenabled = yes
port = 5038
httptimeout = 60
bindaddr =
[username] - your user name in brackets
secret = your password
permit = your IP address

I found the real issue to be the read and write statements…

and here is the http.conf
enabled = yes
bindaddr =
enablestatic = yes

Just uncomment the above lines in the http.conf file on the manager.conf all you need is what is listed above.