GUI does not have necessary privileges


I just installed Asterisk, and i’m trying to access configuration panel.

I’m trying to get here:
localhost:8088/asterisk/static/c … basic.html

but it redirects me here:

So I tried loging in using user and password specified in manager.conf, but it gives the following error:

The GUI does not have necessary privileges.
Please check the manager permissions for the user !

Here is my manager.conf:

; AMI - The Asterisk Manager Interface
; Third party application call management support and PBX event supervision
; This configuration file is read every time someone logs in
; Use the "manager list commands" at the CLI to list available manager commands
; and their authorization levels.
; "manager show command <command>" will show a help text.
; ---------------------------- SECURITY NOTE -------------------------------
; Note that you should not enable the AMI on a public IP address. If needed,
; block this TCP port with iptables (or another FW software) and reach it
; with IPsec, SSH, or SSL vpn tunnel.  You can also make the manager 
; interface available over http if Asterisk's http server is enabled in
; http.conf and if both "enabled" and "webenabled" are set to yes in
; this file.  Both default to no.  httptimeout provides the maximum 
; timeout in seconds before a web based session is discarded.  The 
; default is 60 seconds.
displaysystemname = yes
enabled = yes
webenabled = yes
port = 5038

;httptimeout = 60
; a) httptimeout sets the Max-Age of the http cookie
; b) httptimeout is the amount of time the webserver waits 
;    on a action=waitevent request (actually its httptimeout-10)
; c) httptimeout is also the amount of time the webserver keeps 
;    a http session alive after completing a successful action

bindaddr =
;displayconnects = yes
; Add a Unix epoch timestamp to events (not action responses)
;timestampevents = yes

secret = mysecret
; If the device connected via this user accepts input slowly,
; the timeout for writes to it can be increased to keep it
; from being disconnected (value is in milliseconds)
writetimeout = 100
; Authorization for various classes 
;read = system,call,log,verbose,command,agent,user,config
;write = system,call,log,verbose,command,agent,user,config
read = all
write = all

and here is my http.conf:

; Asterisk Builtin mini-HTTP server
; Whether HTTP interface is enabled or not.  Default is no.
; Whether Asterisk should serve static content from http-static
; Default is no.
; Address to bind to.  Default is
; Port to bind to (default is 8088)
; Prefix allows you to specify a prefix for all requests
; to the server.  The default is "asterisk" so that all
; requests must begin with /asterisk

; The post_mappings section maps URLs to real paths on the filesystem.  If a
; POST is done from within an authenticated manager session to one of the
; configured POST mappings, then any files in the POST will be placed in the
; configured directory.
; In this example, if the prefix option is set to "asterisk", then using the
; POST URL: /asterisk/uploads will put files in /var/lib/asterisk/uploads/.
;uploads = /var/lib/asterisk/uploads/

Any one got any clues?

This is caused by the fact that the GUI application (running on the Asterisk HTTP server) doesn’t have enough permissions to write to the files in /etc/asterisk/

i’m having the same problem. What is the fix?

[quote=“sgtjake”]i’m having the same problem. What is the fix?[/quote]I’m not exactly sure which user is running the Asterisk HTTP service, but you have to give that user full permissions to modify the files in /etc/asterisk
Use chmod to give permissions:

I am getting the same message, after compiling Asterik-Gui

The GUI does not have necessary privileges.
Please check the manager permissions for the user !

I’m having the same problem, after updating yesterday. Before I had the original *Now from CD.
I modifying the owner of all files in /etc/asterisk to raa-web:raa-web (user running ligHHTPd) and the directory-ownership of /etc/asterisk itself. This didn’t help.

So I’m stuck also if nobody has a solution.

Koenraad Lelong.

I am having same issues.

At least whoever wrote the update notes at could tell us what to backup to revers to the old GUI in case of something does not work.

Yesterday evening I tried to chmod 777 everything in /etc/asterisk and /etc/asterisk-gui, but it didn’t help.
Reading the link provided, I’m going to check my http.conf and manager.conf.
If this is unsuccessfull, I’m going to re-install. Unfortunately I didn’t take a snapshot of my virtual machine. Next time I’ll be smarter and I’m going to disable the automatic updates !

Follow the link for my thoughts

I got it working again.
In manager.conf I modified the admin’s read/write lines to include "originate,read,write"
Another thing I encountered is that I had to use a FQDN to enter the gui.