Asterisk CLI will not start under Suse 9 Pro


#1

I’ve installed and uninstalled and installed asterisk several times. I’ve done this process on other distributions and haven’t had a problem. Basically I do a make:make install on zaptel, librpri, asterisk-1.2.7.1, asterisk-add-ons, asterisk-music in that order. Everything seems to work fine, I can log on with an IAX device and everything… But when I try to start up the CLI (asterisk -r), I get this error msg… “Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)”

I go to /var/run and I’m looking right at asterisk.ctl. I tried modifying permissions, and it hasn’t worked. I looked around in asterisk.conf but I don’t know which modification would change things, it all seems fine… Any ideas on what I can do???


#2

Are you sure asterisk is running (“asterisk or asterisk -c”)

-r is to connect to a running asterisk, -c is the console option at startup of the server


#3

Yup, this is what I get… Everything outside of starting the CLI seems to work. Heck, I can even log on with an IAX software phone and I hooked up a management suite and i can do my other things that I need to do, but I can’t get the CLI to work.

Asterisk 1.2.7.1, Copyright © 1999 - 2006 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘show license’ for details.

[ Booting…May 28 09:45:39 NOTICE[20836]: cdr.c:1191 do_reload: CDR simple logging enabled.
.May 28 09:45:39 WARNING[20836]: res_musiconhold.c:838 moh_register: Unable to open pseudo channel for timing… Sound may be choppy.
…May 28 09:45:39 WARNING[20836]: chan_iax2.c:9572 load_module: Unable to open IAX timing interface: No such device or address
…May 28 09:45:39 WARNING[20836]: loader.c:325 __load_resource: /usr/lib/asterisk/modules/codec_gsm.so: undefined symbol: Short_term_analysis_filteringx
May 28 09:45:39 WARNING[20836]: loader.c:554 load_modules: Loading module codec_gsm.so failed!


#4

ok, my guess is that the GSM module isn’t working, and thats preventing the asterisk server from allowing a CLI connection. I looked in the modules.conf, and couldn’t find where the GSM module loads. Any idea where I can play with that or any ways to make it work?


#5

I think that your idea that it is caused by WARNING is not correct. Asterisk is not started if it has ERROR message. If I used command “asterisk -vvvgc” it starts with WARNINGs, too.
I have the same problem as you. I have Asterisk v.1.2.7 under Ubuntu Dapper Drake. When I installed Asterisk by apt-get it runs very well (CLI worked). But after some time and after some Asterisk restarts I lost my connection to CLI by asterisk -r.
I do not know if it is problem of user rights, but it is very big problem for me. Now I solve it by complete Asterisk re-install with old config-files.

David