Asterisk -r: asterisk.ctl doesn't exist?

Just starting to learn asterisk and made it through all the steps of … 35&nav=0,3 just fine, but ran into a snag only when trying to run asterisk now.

I get “unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?”

And of course it does.

If I run asterisk -cvvv, i get a better break down…Error 2786…logger.c init_logger Unable to create event log…Permission denied.

Suggestions anyone?

Don’t know if your problem is the same as the one I had, but the symptoms sound familiar.

How are you starting Asterisk? Via a startup script? If so, try changing it, replacing “asterisk” with “safe_asterisk”. Then have a look at permissions. The user that you’re trying to connect with - does it have rights to access the /var/run/asterisk.ctl file?

Good luck, and keep us posted!

You can try to run asterisk as root. And verify that there are all necessary directories like /var/log/asterisk
Then you can check permissions and solve problems you found.

I tried sudo safe_asterisk, and got 1024 /usr/bin/safe_asterisk: 187 Syntax error Bad fd number?

after installation you must restart your system. with root privilegious you must digit asterisk -rvvvv

asterisk should go!