Asterisk -r failed - does /var/run/asterisk.ctl exist

Hi folks,

installed asterisk 13 on my new centos machine (CentOs Linux release 7.0.1406).
Setup and Installation worked quite well and asterix works fine too (configured some endpoints, registered phones and made calls…).

Only thing is I can’t connect to a running asterisk process via [quote]asteriks -r[/quote]. Always get the message ‘Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)’.
Strange thing here is, that that file exists in [quote]/var/run/asterisk[/quote] and [quote]/run/asterisk[/quote].
Of course I started asterisk via [quote]/etc/init.d/asterisk start[/quote] before and also [quote]/etc/init.d/asterisk status[/quote] shows me that asterisk is running.

So currently I’m forced to start asterisk with [quote]asterisk -c[/quote] to get it running and have a look at cli at the same time.

btw: the only module I added to asterisk is pjproject, no dahdi, no libpri.

edit: asterisk is installed under su and I’m su too when trying to connect to cli

What am I missing?
Suggestions would be very appreciated.

Does no one have a clue?

I’ve never seen this when the file exists, but I would check:

  1. is there a permissions problem;

  2. is the asterisk server actually running.

As I said in my first post im su when I start the ASterisk daemon and I’m su too when trying to connect to the daemon via [quote]asterisk -r[/quote]
So I don’t think there’s n permission problem.

And Asterisk daemon does run, because I [quote]/etc/init.d/asterisk status[/quote] shows me n active (running) status of asterisk daemon.

I’m not quite sure if I understand this whole thing correct by now.
I should be able to connect to CLI when the daemon is running, shouldn’t I?

There are multiple cause why this issue could happen. In ma cased was solved disabling the selinux

setenforce 0