Aastra 9133i refuses to except firmware image after crash

Got a case where a few of our test phones will no longer except the firmware.
I can log into the phones firmware page where its asking for the ip address of the tftp server and another line ask for the file. It will say invalid selection or something like this. I tested the tftp server with a tftp client and all works fine.

The options button on the phone refuses to work. So we are stuck. Nothing has come up on google for this issue. So if anyone knows how to reset these phones where the options button will work would be helpfull.


Download the firmware from aaatra , unzip it an put it in your tftp directory do not change the filename. Then either set your dhcp server to set the tftp server address or set it via the GUI after doing a factory reset then with the tftp server address set restart the phone.


Since I did not have a dhcp server aviable, I set the ip address address and subnet as that of the phone. The phone will be in web recovery mode with its own display set on the screen. I can log into the embeded web server on the phone via the PC its hooked to. I have tested the tftp server with a tftp client to download the specific 9130i.st file and it worked. But when trying the same via the phones embeded server, get a message of invalid specification in red or something close to those words.

Can this be done in static mode? have you tried it in static mode?




Sorry I have only updated firmware via tftp automaticly, It would take too long to do it manually

But I do have a site with 155+ handsets with static IPS and no problems with upgrades.


These were working phones. But after thay were rebooted, these phones some how lost there formware flash image. The option button would not work so could not change the ip address on the phones. But the question really is, do you need a dhcp server for the phone ? I would think not if the phone was on the same network subnetwork as the tftp server. I could set up a dhcp server but I will still need to log into the phones embeded web server and enter in the 9133i.st file and ip address of the tftp server. I feel in this case, it will be moot and would end up with a phone that does not want to except the image.


How do you deploy your handsets, the normal way is via DHCP and then that gives the phone the tftp server address. the phone its self knows the default filename for its firmware and as long as a copy is in the tftp directory and its newer than on the phone it will download it.

you will need a aastra.cfg and a .cfg as well

I do not ever log onto handset web guis, all settings are passed via the config file.


so the phones are in web recovery mode. I am going to call aastra this morning and see what can be done. The phones TWO line web recovery embeded web page ask for the 9133i.st and the tftp server address. I put in the correct info and get back a red text reply of invalid perameters. Kinda at my wits end. Tested the tftp server with a tftp client and was able to pull the st file from it.


Aha you hadnt mentioned they are in web recovery mode.
This is a very different kettle of fish

You need to follow the instructions in the admin guide, But basicly the best way is to use a laptop with a tftp server running as you have to set the address to a 169 address, havent got notes to hand so say what it should be.
But basicly in this mode all you can do is follow the instructions

help.pbxtra.com/IP_Phones/Web_Re … tra_phones

or follow this

[quote]If the phone displays: “Web
recovery at: â€

Did everything to a T. I installed a TFTP server, then installed a tftp client. Sent a request from the client to the server both its ip address and the file specified and was able to pull it off the server.

In the case of the phone, was not able to pull the file off the server. Both IPS of the phone server are the same but the server is .64 and phone end ip .63