5 second outgoing dial delay


#1

Hi, when i dial out theres a 5 second delay between the Dial() and when my trunk acctualy starts ringing. other people i have talked with on irc say theirs is instant. im using a digum tdm400p with x100 fxo modules with POTS. my pc is a P4 2.4GHZ with 1GB ram. incoming calls are very quick. about 2.5 seconds before they start to ring. here is my * log of the part with the delay: and my zapata.conf. any suggestions will be greatly appreshiated!

Jan 31 21:31:10 VERBOSE[3061] logger.c: – Executing Dial(“SIP/100-5196”, “ZAP/3/99025896”) in new stack
Jan 31 21:31:10 DEBUG[3061] chan_zap.c: Dialing '99025896’
Jan 31 21:31:10 DEBUG[3061] chan_zap.c: Deferring dialing…
Jan 31 21:31:10 VERBOSE[3061] logger.c: – Called 3/99025896
Jan 31 21:31:11 DEBUG[3061] chan_zap.c: Exception on 21, channel 3
Jan 31 21:31:11 DEBUG[3061] chan_zap.c: Got event Hook Transition Complete(12) on channel 3 (index 0)
Jan 31 21:31:13 DEBUG[3061] chan_zap.c: Exception on 21, channel 3
Jan 31 21:31:13 DEBUG[3061] chan_zap.c: Got event Dial Complete(9) on channel 3 (index 0)
Jan 31 21:31:13 DEBUG[3061] chan_zap.c: Enabled echo cancellation on channel 3
Jan 31 21:31:13 DEBUG[3061] chan_zap.c: Engaged echo training on channel 3
Jan 31 21:31:15 DEBUG[3061] chan_zap.c: Exception on 21, channel 3
Jan 31 21:31:15 DEBUG[3061] chan_zap.c: Got event Dial Complete(9) on channel 3 (index 0)
Jan 31 21:31:15 DEBUG[3061] chan_zap.c: Echo cancellation already on
Jan 31 21:31:15 DEBUG[2618] channel.c: Avoiding initial deadlock for 'Zap/3-1’
Jan 31 21:31:15 VERBOSE[3061] logger.c: – Zap/3-1 answered SIP/100-5196
Jan 31 21:31:15 DEBUG[2618] channel.c: Avoiding initial deadlock for ‘SIP/100-5196’

;zapata.conf

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=yes
callwaiting=no
usecallingpres=no
callwaitingcallerid=no
threewaycalling=no
transfer=no
cancallforward=no
callreturn=no
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no

;faxdetect=both
;faxdetect=incoming
;faxdetect=outgoing
faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

;Include AMP configs
#include zapata_additional.conf

;zapata-auto.conf
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 3
context=from-pstn
group=0
channel => 3


#2

Try using ground start


#3

i can’t seem to get ground start to work. i keep getting the following error when trying to run ztcfg. i tried loop start and that worked but didn’t speed up the dialing times, same delay. heres the ground start error i got:

Zaptel Configuration

Channel map:

Channel 01: FXS Groundstart (Default) (Slaves: 01)
Channel 02: FXS Groundstart (Default) (Slaves: 02)
Channel 03: FXS Groundstart (Default) (Slaves: 03)
Channel 04: FXS Groundstart (Default) (Slaves: 04)

4 channels configured.

Changing signalling on channel 1 from FXS Loopstart to FXS Groundstart
ZT_CHANCONFIG failed on channel 1: Invalid argument (22)


#4

oh and heres my config files:

;zaptel.conf

Span 1: WCTDM/0 “Wildcard TDM400P REV I Board 1”

fxsgs=1
fxsgs=2
fxsgs=3
fxsgs=4

Span 2: ZTDUMMY/1 “ZTDUMMY/1 1”

Global data

loadzone = us
defaultzone = us

;zapata.conf

; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_gs
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=yes
callwaiting=no
usecallingpres=no
callwaitingcallerid=no
threewaycalling=no
transfer=no
cancallforward=no
callreturn=no
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no

;faxdetect=both
;faxdetect=incoming
;faxdetect=outgoing
faxdetect=no

callerid=asreceived

; Span 1: WCTDM/0 "Wildcard TDM400P REV I Board 1"
signalling=fxs_gs
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-pstn
group=0
channel => 1

signalling=fxs_gs
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 2
context=from-pstn
group=0
channel => 2

signalling=fxs_gs
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 3
context=from-pstn
group=0
channel => 3

signalling=fxs_gs
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 4
context=from-pstn
group=0
channel => 4

; Span 2: ZTDUMMY/1 “ZTDUMMY/1 1”


#5

Try this zapata.conf:

[channels]
context=from-pstn
musiconhold=default
langage=en
echocancel=64
echotraining=800
echocancelwhenbridged=yes
;rxgain=0
;txgain=0
group=1
faxdetect=no
signalling=fxs_ks
channel => 1-4


#6

I’m having the same problem so I was wondering what changes you’re suggesting, and why? Zodiacal, will you please post if this worked or not? Thanks!

[quote=“zmanea”]Try this zapata.conf:

[channels]
context=from-pstn
musiconhold=default
langage=en
echocancel=64
echotraining=800
echocancelwhenbridged=yes
;rxgain=0
;txgain=0
group=1
faxdetect=no
signalling=fxs_ks
channel => 1-4[/quote]


#7

nope, didn’t speed things up… any suggestions on where to go from here?


#8

oh and surmond, do you get those same exeption events? im wondering if they are some kind of error message… i got a response back form digum telling me to test by putting a simple .call file in the asterisk/outgoing directory. this still had the delay if anyone has any ideas they would be greatly appreshated!


#9

No, I don’t get those exception events.


#10

What versions of Asterisk, Libpri, and Zaptel are you running? Does the same thing happen if you call out on line 1 or 2? Any idea on how far away from the CO you are?


#11

im running the latest versions. i have tried with asterisk 1.2.1, 1.2.2, 1.2.3, 1.2.4. same thing happens…

heres the latest versions numbers:
asterisk 1.2.4
zaptel 1.2.3
libpri 1.2.2

i have tried on a few of the lines i have, i have 6 phone lines here. same delay.

When i don’t use asterisk, a normal phone can dial out immediatly with no delay. im guessing this means its not a problem with the phone lines… any thoughts?


#12

My guess is it depends on when your CO provides the ring tone. It could also be that the normal phones you have might provide you with a “fake” ring tone while it is still setting up communications with the CO.

You can “fake” that delay by adding the following, “s,n,Ring” before your Dial command. In this case Asterisk is providing the ring tone to the phone but we had problems with that since it seems to have a problem when you dial a number that has auto answer on and basically answering the line immediately. Like IVR systems.


#13

but if i use two normal analog phones, i.e. line one calling line two. they BOTH ring instantly. maybe i miss understood you tho, are you talking about somthing other than just having the calling party hearing a ring while still having the called party wait for a ring?


#14

I am having the same problem with a delay of 6 second from the time a zap channel is called until it answers. Any one has an update solution?


#15

nope, i even tried exchanging the cards for a different revision, still the same problem. my only sollution is to bare thru it now and resolve it in the future with voip thru my internet , but i have to wait until i have enough bandwidth for that… the tech support at digium even said that it shoudn’t be doing this, but they coudn’t find a solution either and i needed to move on allready…