Dial * / FXO module ring / correspondant answer / and *

Hello All,

I’ve just setup TDM2400 (12 FXO/8FXS). I’ve two problem :

When I’m making a call to landline or GSM with :
The called has the ring signal
5-6 secondes after : the “called” has the ring signal,
The called answer but asterisk doesn’t detect and the caller continue to get the ring signal.

When I try with :
5-6 secondes after the Caller and the Called has the ring signal
The called answer and asterisk we can talk !

So, how can I solve this big proble ?
How can I reduce the delay to Dial a correspondant ?

The inbound work without pb… (just the caller id doesn’t print under the GXP 2000)

I’m in French west indies region (Martinique).

Thank you for for your help,

You could try doing a Playtones(ring) before dial(), that might give you some rings until the line actually starts ringing.

however there isnt much to be done about the delay, remember with an analog channel * must pick up, dial the number, then ringing will eventually come from the other side…

Thank you for your repply.

I’ve tried a playtones in my Dial plan but nothing append…
Here is the CLI trace :

-- Starting simple switch on 'Zap/47-1'
-- Executing PlayTones("Zap/47-1", "425/1000|0/4000") in new stack
-- Executing Dial("Zap/47-1", "Zap/g1/XXXXX") in new stack
-- Called g1/XXXXXXX

The Dial(Zap/g1/${EXTEN},60,r) : This “r” give me the “impression” that my correspondant is ringing… But as you could read before, this method with Zap & TDM gave me some pb.

This method work fine with PRI (TE110P) and BRI channel… So, I think that my pb is in my zapata.conf / zaptel.conf (country sepicity ?)

That my first time TDM & FXO Module…


I believe your problem is in zapata.conf.

I had almost the same problem in UK with asweronpolarityswitch=yes on a line which did not provide answer supervision. With this on it waited for ever for the remote end to answer.

Once turned off it assumed answer immediatly and turned call audio over to the pstn line so all the signalling came from there.

Hope this is of use.

Tried but… not better…

here is my zapata :

; Lignes FT


usecallerid => yes
callerid => asrecived
signalling = fxs_ks
channel => 60
channel => 65
channel => 57

group = 1
channel => 58-59
channel => 61-64

Ok, next one is callprogress. Have you tried callprogress=no? I have a little note I made to myself which says: “callprogress=yes Caused fail to answer on BT line”, shich sounds similar to your problem.

Aslo, beware of busydetect, it can cuase random cuttoffs in some countries, it certaily did for me. However, it will not affect your current problem at all.

I think I may be trying to solve the wrong problem. I think you may already have it working how I do and we simply have different expectations!

Tested and strange result !!

Dial(Zap/g1/${EXTEN},60,r) is now working :
– Starting simple switch on ‘Zap/47-1’
– Executing Dial(“Zap/47-1”, “Zap/g1/XXXXXXX||r”) in new stack
– Called g1/0596428121 - >I’ve a ringtone and
– Zap/58-1 answered Zap/47-1 -> I’ve Nothing
– Attempting native bridge of Zap/47-1 and Zap/58-1 -> For a GSM I’ve 2-4 sec blank and new rings

Voice forward is ok.

So the result is not perfect but, it’s ok.

I’ve now another PB… Asterisk does not detect hang up of the correspondant.
Imagine : I’m calling office from home, the operator answer and I’m asking to forward to someone else, the transfert is done but nobody answer. So I’m hanging-up and the phone is continuing to ring…

Result : * doesn’t detect that I’ve hanked up.

I’ve read this page… So my case seams to be similair…
voip-info.org/wiki/index.php … upervision

but I wasn’t able to fix it.
The problems are very closed… But, could not fix it.

Any idea ? Florent