ZTDUMMY stealing span1!


I’ve had a search but couldn’t find an answer that fixes my problem. I have a Sangoma A102 E1 card and the Wanpipe drivers are installed.

The problem is ZTDUMMY is loading before wanpipe and taking over SPAN1. I tried re-initialising wanpipe by going to the source dir and executing ./Setup install-init. But This had not fixed the problem.

Asterisk appears to work ok. But when it starts is complains that SPAN1 isn’t SPAN1 and says it’s using SPAN2 instead.

Looking at dmesg when Wanrouter starts it complains.
“WARNING: Span number 1 is already used by another device!
Possible cause: Another TDM driver already loaded!
Solution: Unload wanpipe and check currently
used spans in /proc/zaptel directory.
Reconfiguring device wanpipe1 to new span number # 2”

I’ve checked /proc/zaptel and ztdummy is stealing Span1

Does anyone know how to fix it so the system boots up in the correct order?
(I can fix it manually by unloading everything and modprobing ztdummy after I have loaded wanrouter.)

( I’m trying to rule this out as an issue which is causing my ISDN PRI break with this error: “Mar 28 09:13:33 NOTICE[2236] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 2

Thanks, liam

I don’t suppose you need ztdummy if you use an E1 card. So why not blacklist it or better, remove it from the disk? With more recent zaptel, you can also make select to not compile ztdummy at all.

Hmm I thought I did need ZTDUMMY. It’s not a Digium card which has its own hardware clock. All the stuff I read when I setup the system was that ZTDUMMY was required when using the Sangoma card.

I specifically compiled in ZTDUMMY - I suppose I can recompile without it.

Can anyone confirm whether I do actually need ZTDUMMY with a Sangoma A102 card?

Cheers, Liam

Not Sure Liam, but let us know what happens if you do remove ZTDUMMY though, i am interested as i have a Sangoma A104D Card and am also interested in weather or not ZTDUMMY is needed as well.




I tried removing ZTDUMMY for an afternoon and I didn’t get any problems with onhold music, voicemail or calls quality. But … Our telco has replaced the card in the exchange which provides our E1 circuit so I’m not going to make any changes to Asterisk for about 4 days to see if that solves my line dropping.

So I’ll properly remove ZTDUMMY later next week and see what happens.

Cheers, Liam