Zaptel ZapSendKeypad Facility error after upgrade 1.4.12

To begin with, this problem is solved - hopefully this might save someone a lot of grief trying to figure out why their zap channels mysteriously disappeared after an upgrade to 1.4.12.

With the upgrade to 1.4.11 and 1.4.12 I experienced problems with * not recognizing the TDM400 cards. Everything would appear to load correctly, and genzaptelconf seemed to work, and the /etc/default/zaptel configuration file seemed correct. Even ztcfg seemed to recognize the card. However, when asterisk was started chan_zap was missing!

When I tried loading I got an error regarding ZapSendKeypad Facility and channel 1 not loading.

A copy of zaptel.conf was as follows:

Autogenerated by /usr/sbin/genzaptelconf – do not hand edit

Zaptel Configuration File

This file is parsed by the Zaptel Configurator, ztcfg

It must be in the module loading order

Span 1: WCTDM/0 “Wildcard TDM400P REV I Board 1”


Global data

loadzone = us
defaultzone = us

For whatever reason, genzaptelconf configured my zaptel.conf to use loopstart. My system needed kewlstart. And until it got what it wanted, it didn’t work. So, where genzaptelconf set “fxols”, I changed it to “fxoks” and happily ran ever after.

If you’re running into similar problems check ZAPTEL.CONF!