[Resolved] Zap channel driver not recognized w/1.4.2


I just attempted to upgrade my 1.4.1 box to 1.4.2. I deleted all of the existing modules under /var/lib/asterisk/modules, then recompiled zapata-1.4.0 and libpri-1.4.0. After running configure and make menuselect, I discovered that the chan_zap channel was XXX’ed out under Channel Drivers.

Assuming a dumb ass attack on my part, I recompiled everything a second time and had the same results.

I went back to asterisk-1.4.1 and after running configure and make menuselect chan_zap was available.

I have a TDM400 card installed, so zaptel is not optional. Anyone else experiencing a similar problem?

I just dl’d 1.4.2 and ran it as far as make menuselect; result - chan_zap has a * here. Did menuselect give you any information as to what it thought was missing?

i think there’s something “missing” in zaptel-1.4.0 … IIRC the advice is to download svn trunk of zaptel and use that with 1.4.2

I also had a similar issue, after I compiled 1.4.2 i noticed the zap channel driver is not loaded, i will try the advice above and download the latest trunk for zaptel and compile that in … ill report back

Moving over to an svn release of zaptel solved the problem. Thanks very much baconbuttie!

UPDATE: Zaptel 1.4.1 was just released. Asterisk 1.4.2 immediately recognized the zaptel 1.4.1 driver, so there’s no need to resort to the svn version.

[quote=“afried”]Moving over to an svn release of zaptel solved the problem. Thanks very much baconbuttie!

I’d like to see Digium release a 1.4.2 version of zaptel - using svn versions makes me a little nervous.[/quote]

Hey Afried, just so it is easier for guys like us :wink: can you please edit your Thread Heading making it state that it is [Resolved], helps us to see what topics have been resolved and what ones haven’t, also helps those looking for answers to the same problem to know to look at your thread :wink: