Obscure ZT_CHANCONFIG failed on channel 1 problem


#1

Hi,

The main symptom is that I cannot get the TDM400P card to work, when I run ztcfg I get:

ZT_CHANCONFIG failed on channel 1: No such device or address (6)

I have researched the web extensively but none of the resolutions for this error message work for me…

In Detail:
I am trying to install a TDM400P with two FXO modules in slots 3 and 4 into a nforce 3 motherboard with Mandriva 2006.
I have urpmi’ed the asterisk, zaptel and zaptel-tools.

“modprobe wctdm” produces the following /var/log/messages:
pam_console.dev[5878]: Restoring console permissions for /dev/zap/timer
pam_console.dev[5886]: Restoring console permissions for /dev/zap/channel
pam_console.dev[5898]: Restoring console permissions for /dev/zap/pseudo
kernel: Zapata Telephony Interface Registered on major 196
pam_console.dev[5908]: Restoring console permissions for /dev/zap/ctl
hald[3692]: Timed out waiting for hotplug event 1065. Rebasing to 1095

lsmod | grep wc
wctdm 29568 0
zaptel 178468 1 wctdm

When I try and run ztcfg as part of the start-up, I get:

ztcfg -vvv
Zaptel Configuration
======================
Channel map:
Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
2 channels configured.
ZT_CHANCONFIG failed on channel 1: No such device or address (6)

My /etc/zaptel.conf is:
fxsks=1-2
loadzone=au
defaultzone=au

lspci shows:
02:09.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface

but a cat /proc/interrupts does not show the card.
0: 1605517 IO-APIC-edge timer
1: 882 IO-APIC-edge i8042
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-level acpi
12: 11508 IO-APIC-edge i8042
14: 68777 IO-APIC-edge ide0
16: 5 IO-APIC-level bttv0, bt878, ohci1394
17: 120138 IO-APIC-level nvidia
18: 27667 IO-APIC-level libata, bttv1, bt878
20: 3734 IO-APIC-level ehci_hcd:usb3, NVidia CK8S
21: 159687 IO-APIC-level ohci_hcd:usb2, eth0
22: 0 IO-APIC-level ohci_hcd:usb1, libata
NMI: 0
LOC: 1605469
ERR: 0
MIS: 0

I have had the card replaced and I have tried 4 different PCI slots, each slot exhibits the same symptoms.
I have also tried removing all other PCI cards except the graphics card and the TDM400P.

Any help would be greatly appreciated as I have spent many hours on this but have been unable to find a solution thus far.

Thanks.


#2

Not sure why the Mandriva urpmi zaptel packages did not work, but compiling zaptel from CVS works.
(I still used the Mandriva urpmi asterisk package though).

For those of you that have symptoms such as mine, I suggest try following exactly what is described at this article.
voip-info.org/tiki-index.php … stallation

The only variation is where it says to modify files:
/etc/udev/rules.d/50-udev.rules and
/etc/udev/rules.d/50-udev.permissions
use:
/etc/udev/rules.d/50-mdk.rules
/etc/udev/rules.d/50-mdk.permissions
as this is where the Mandriva urpmi asterisk package has already done some of the work.

Good Luck.