Zaptel->dahdi migration: Not finding card

I just did an OS update on my PBX machine, including an OS reinstall (FreeBSD 8.2)… this meant grabbing newer versions of everything, so I’m moving from zaptel to dahdi. My current install includes the ports:

I basically copied my old zapata.conf file verbatim to the dahdi system.conf:
loadzone = us

However, dahdi doesn’t seem to be recognizing my Digium card. I get nothing (an empty list) from dahdi_tool, and dadhi_cfg gives me the content pasted below.

I’ve done a reboot just to be sure everything’s loading. The only thing dahdi-related in dmesg is:
dahdi: Telephony Interface Registered on major 196
dahdi: Version: 2.4.0-rc5

It looks like everything from the upgrade is working except this one piece. Any thoughts on what I might be missing?

sudo dahdi_cfg -vv
DAHDI Tools Version - 2.4.0-rc1

DAHDI Version: 2.4.0-rc5
Echo Canceller(s):

Channel map:

Channel 01: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Echo Canceler: none) (Slaves: 02)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: none) (Slaves: 04)

3 channels to configure.

DAHDI_CHANCONFIG failed on channel 1: Device not configured (6)

try with dahdi_hardware to know if dahdi see your card.

if yes, use dahdi_genconf to configure the card. What model is the card?

Sure. Any idea where I can find either of those? The dahdi port on FreeBSD doesn’t include either one. I tried compiling the dahdi-tools package from the Asterisk site, but it claims to require the Dahdi Linux kernel modules… and since I’m not running Linux…

As for the model card, I couldn’t quote you the model number. It’s been three or four years since I bought the card. It’s a four port PCI card that takes daughter boards to turn them into fxs or fxo ports. I’ve got three boards on mine for two fxo ports and one fxs.

Hey Matt,

I just went through the same thing. Sounds like you and I have the same PCI card. I solved it by adding this to /etc/rc.conf


Then the wctdm kernel module gets loaded correctly. Before adding that line I was not seeing this in /var/log/messages:

Jul 1 12:43:02 pbx kernel: wctdm0: vendor=e159 device=1 subvendor=b119
Jul 1 12:43:02 pbx kernel: wctdm0: port 0xd800-0xd8ff mem 0xff101000-0xff101fff irq 10 at device 13.0 on pci0