Zaptel and FC5-x86_64

Okay gang, no matter how hard I try it doesn’t work and the question seems to keep going over everyone’s head. The forum and #asterisk chat have not been able to help thus far…So I’m really desperate now…

I’m running FC5-x86_64 with kernel 2.6.15-1.2054. I need the kernel sources installed to get zaptel to compile. So I did this:

yum install kernel-devel

and that started installing the sources for 2.6.18 kernel…not my kernel. So I updated the kernel to 2.6.18 and this machine went haywire…I don’t know what happened but I’m really not trying to update the kernel unless absolutely necessary. The machine was so whacked out I had to reinstall FC5-x86_64 again. Back to square 1.

I then followed the instruction in the docs file:///usr/share/doc/HTML/index.html#id287544 and at least got what appears to be the sources for 2.6.15-1.2054-x86_64 installed in my home directory under the rpmbuild folder. But when I followed the remaining instructions in this doc I just ended up with another error:

cd ~/rpmbuild/SPECS

rpmbuild -bp --target $(uname -m ) kernel-2.6.spec

Illegal variable name

So I tried to proceed anway. But when zaptel compiles it seems to be looking for something in /lib/modules. I found what it’s looking for in there but it’s just a link to a non-existent folder in /usr/src. So I created the missing folder (/usr/src/kernels) and made a link inside of it to the rpmbuild folder in my home directory. zaptel got a little further this time (little is right) it tried to look into this link but then complained there was no makefile present.

I’m not really a programmer and all this linking stuff is just a bunch of spaghetti to me. So can anyone please tell me how to get zaptel to build on FC5-x86_64…Please don’t tell me how to do it on FC5-i386 even if it’s the same…I’m not running i386…HEAR THAT…I’m not running i386

uname -a

Linux localhost.localdomain 2.6.15-1.2054_FC5 #1 SMP Tue Mar 14 15:48:20 EST 2006 x86_64 x86_64 x86_64 GNU/Linux

The next person who tries to convince me I’m not running x86_64 will be shot with a water pistol full of moose urine.

A few more google searches show that this is a common problem for other drivers as well. The makefile for zaptel starts looking for /lib/modules and /usr/linux and 2.4…everything except what I’m trying to do. I am not a programmer so it will take me some time to try and work through this. I guess I’ll have to write my own HOWTO on this but you’d think that the zaptel people would have a fix for this…like bsd_zaptel, I guess we need an FC_zaptel version.

For the last time…Linux, Centos, Debian, Ubuntoo, etc…take a lesson from FreeBSD and use standards that work for more than just your flavor of Linux. Not all of us are programmers with the knowledge it takes to configure a makefile…but alot of us can get asterisk running and allow more users to experience the freedom from legacy pbx systems…that is if we can get past all the jargon and symlinks.