Asterisk-1.4 beta3 on FC5 x86_64

I just built a new system today with FC5 x86_64. It’s an AMD 64 box and it’s been running Windows XP. The FC5 x86_64 install went okay but when I tried to build zaptel-1.4 beta2 I got the following error message when I ran “make clean”:

grep: /lib/modules/2.6.15-1.2054_FC5/build/include/linux/autoconf.h: No such file or directory
make[1]: Entering directory /usr/src/asterisk/zaptel-1.4.0-beta2/menuselect' rm -f menuselect *.o make[1]: Leaving directory/usr/src/asterisk/zaptel-1.4.0-beta2/menuselect’
rm -f torisatool makefw tor2fw.h radfw.h
rm -f fxotune fxstest sethdlc-new ztcfg ztdiag ztmonitor ztspeed zttest zttool
rm -f *.o ztcfg tzdriver sethdlc sethdlc-new
rm -f libtonezone.a *.lo
make -C /lib/modules/2.6.15-1.2054_FC5/build SUBDIRS=/usr/src/asterisk/zaptel-1.4.0-beta2 clean
make: *** /lib/modules/2.6.15-1.2054_FC5/build: No such file or directory. Stop.
make: *** [clean] Error 2

I’m not all all a programmer so I was hoping someone could point me in the right direction here.

looks like a mismatch between your running kernel and the sources you have installed (if any). do you have a directory /lib/modules/2.6.15-1.2054_FC5 ??

Thanks very much for your reply. I’m a FreeBSD junkie so this FC5 os is new territory for me. I do have a folder /lib/modules/2.6.15-1.2054_FC5. Inside of this folder is a link to “build” but it shows in the file manager program as a “broken link”. When I installed the os I did not download and/or install any sources…to be honest I’m again not that familiar with Linux and wouldn’t know how to do that. Especially since I saw the SOURCES on an FTP site yesterday and there’s 5 cd iso images, each in excess of 640MB. With FreeBSD you install the kernel sources with a simple download that takes only a few minutes. So if you could point me in the right direction here I think I can handle this.

Thanks again.

the sources you refer to will be the source for all the packages you have available on install. you’re only interested in the kernel source. you can either find it manually on the install disk and use RPM to install it, or if you’ve installed a GUI, run whatever package manager you installed.

I am just a newbie at this but after three hours I still can’t get zaptel to compile on this FC5-x86_64 box.

I have asked in the chatrooms and while there are helpful people there no one has been able to give the correct information. I built this system with the install CD’s and FC5 does not install the kernel sources. So I followed several steps outlined in some google and yahoo searches as well as the chatroom participants. The only files I can find in the download areas are for FC5 not FC5-x86_64 and I’m afraid I’m going to overwrite something. This morning I followed some docs and ended up whacking the system so bad I had to rebuild it.

The only source files (I think) I can find are in the source directory in the mirrors and not under the x86_64 folders. Can someone point me in the right direction here?

zaptel looks for something in /lib/modules/ which then links to /usr/src/kernels…I can’t follow all this spaghetti (pointers to pointers) stuff very easily and keep missing the point…?

what does “uname -a” return ?

i would install the kernel-2.6.15-1.2054.FC5.src.rpm that’s on the mirrors, as you don’t appear to be running a _64 kernel according to the zaptel make.

uname -a =
Linux localhost.localdomain 2.6.15-1.2054_FC5 #1 SMP Tue Mar 14 15:48:20 EST 2006 x86_64 x86_64 x86_64 GNU/Linux

I think everyone assumes I’m not running x86_64 kernel. But I installed from the x86_64 iso images. That much I know. What I’m afraid of is that I cannot find the .src file for this kernel on the Fedora mirror sites. There is a kernel-2.6.15-1.2054_FC5.src.rpm file on each mirror and it’s not located under the x86_64 folder. But I’m worried this is not the kernel source for the x86_64 kernel it’s for the i386 kernel. Matbe I’m wrong but this morning I rendered this system useless by following the docs someone told me to use and had to reinstall the os to clean it up.

This machine is an AMD64 processor so I assume it’s okay to run the x86_64 version of Fedora on it. Thanks again and any further advice would be appreciated.