Zap here - then gone


I’m just installed Asterisk 1.4.10, Zaptel 1.4.4 .

Asterisk CLI showed the “zap show” commands available (using “help”) and they worked - I used them to show the status of a Rhino card I have installed.

Then I rebooted the machine - and now the “zap” commands are not available in Asterisk.

In an “attempt” to fix the problem, I reinstalled zaptel and asterisk and somehow caused the commands to show again - yet again - after a reboot - they are gone.

I’m tottaly new to Linux, however have many many years of system programming on mainframes. I’m sure this is something I’m doing wrong somewhere - I just don’t know where.

Any assistance would be greatly appreciated. Thanks!

sounds like the zap modules aren’t being loaded by your OS.

check out the modprobe section in the following … /x291.html

I will take a look.

I see now that if I run ztcfg after I reboot everything works fine.

I guess I just need some direction on now to set things up where they start automatically after a reboot.

Thanks for the link.

I read that link and I’m still not sure I completely understand what is required or why doing “ztcfg” after booting “fixes” the problem.

Can someone help me with what I need to set up to have Asterisk (including zaptel) start automatically after a boot (unattended)?

Thanks for your help.

I have a few lines in my /etc/rc.d/rc.local like so:

service zaptel start sleep 5 amportal start

I do not have either zaptel or asterisk auto-starting as services, I found that caused problems. They seem fine if started later by rc.local

Thanks for your help.

I assume that amportal starts Asterisk?

Yes, I use FreePBX as a front end for configuration.

amportal starts both Asterisk & Flash Operator Panel.