Yum installation on Centos 5.4

I’m trying to install Asterisk as described in dedicated page “Installing Asterisk with YUM”, but all I got is:

Transaction Check Error:
package kernel-2.6.18-194.8.1.el5.i686 (which is newer than kernel-2.6.18-194.3.1.el5.i686) is already installed

Is there something I can do without compromising my Centos installation?

What is your current kernel version?

[root@localhost ~]# uname -r

A few days ago I was upgrading a system and there’s still no dahdi kmod for kernel-2.6.18-194.8.1. So stick with 2.6.18-194.3.1.el5 and make sure you have kmod-dahdi-linux-2.3.0.1-1_centos5.2.6.18_194.3.1.el5