SOLVED - Dahdi Yum install issue


#1

Hello,

Forgive me if I’m missing something obvious, but I think there’s a typo in the yum dependencies in some of the dahdi stuff from the Asterisk/Digium digium-current Yum repository.

We’re looking to reform ourselves from a Trixbox shop to an Asterisk one. We provide phone systems for several different customer locations. We’ve been to the intro class in Huntsville. We’re pretty well versed in CentOS/Fedora/Red Hat.

I have a brand new CentOS 5.6 install that has been updated. Nothing else is on the system. After I add the Asterisk/Digium repositires and try to install asterisk18, I get

[color=#0000FF]# yum -y install asterisk18

–> Missing Dependency: kernel-x86_64 = 2.6.18-238.19.1.el5 is needed by package kmod-dahdi-linux-fwload-vpmadt032-2.5.0-1_centos5.2.6.18_238.19.1.el5.x86_64 (digium-current)

yum list | grep ^kernel

kernel.x86_64 2.6.18-238.el5 installed
kernel.x86_64 2.6.18-274.3.1.el5 installed

#[/color]

There is no “kernel-x86_64” only a “kernel.x86_64”. I had the same problem when I tried it with CentOS 5.7.

I got the repo information from https://wiki.asterisk.org/wiki/display/AST/Asterisk+Packages#AsteriskPackages-YUM%28CentOS%2FRedHat%29

[color=#0000FF]# pwd
/etc/yum.repos.d

cat centos-asterisk.repo centos-digium.repo

[asterisk-current]
name=CentOS-$releasever - Asterisk - Current
baseurl=http://packages.asterisk.org/centos/$releasever/current/$basearch/
enabled=1
gpgcheck=0
#gpgkey=http://packages.asterisk.org/RPM-GPG-KEY-Digium

[digium-current]
name=CentOS-$releasever - Digium - Current
baseurl=http://packages.digium.com/centos/$releasever/current/$basearch/
enabled=1
gpgcheck=0
#gpgkey=http://packages.digium.com/RPM-GPG-KEY-Digium

#[/color]

Did I miss something or is there a problem? I know I can build it from scratch, but everything else we do comes from Yum if not CentOS, then RPMForge. We’d really like to be consistent and use Yum for Asterisk as well.

Suggestions?

Thanks,

Cedric


#2

I’m having a similar problem with CentOS 5.7 and Asterisk 1.8

[root@interface ~]# [color=#00BF00]uname -a[/color]
[color=#FF8000]Linux interface 2.6.18-274.3.1.el5.centos.plus #1 SMP Wed Sep 19 05:39:08 EDT 2011 i686 i686 i386 GNU/Linux[/color]

Using yum and the centos-asterisk and centos-digium repositories, it wants to install:
kernel 2.6.18-274.3.1.[color=#FF0000]el5[/color], but I’m already running 2.6.18-274.3.1.[color=#FF0000]el5.centos.plus[/color]

I only got the above error after I’d run:
[color=#00BF00]yum --skip-broken install asterisk18[/color]

If I don’t us the --skip-broken switch, then it gives me considerably more errors related to the digium packages. Such as:

[color=#FF8000]kmod-dahdi-linux-fwload-vpmadt032-2.5.0-1_centos5.2.6.18_238.19.1.el5.i686 from digium-current has depsolving problems
–> Missing Dependency: kernel-i686 = 2.6.18-238.19.1.el5 is needed by package kmod-dahdi-linux-fwload-vpmadt032-2.5.0-1_centos5.2.6.18_238.19.1.el5.i686 (digium-current)[/color]

I’ve tried booting with the 2.6.18-238.19.1 kernel, but again, I’m using this kernel: kernel-2.6.18-238.19.1.[color=#FF0040]el5.centos.plus[/color], and not 2.6.18-238.19.1.[color=#FF0000]el5[/color]

Any hints would be greatly appreciated. I can provide any additional detail that is required.

Thanks!

[color=#FF0000]CORRECTION:[/color] I was wrong on so many levels… It turns out I had the CentOS Plus repositories turned on. Must have done it and forgotten. Now my kernels are all updated too… Once I figure out how to revert back to the normal CentOS stream, I’ll probably have much more luck. Sorry for any confusion.


#3

I just tried a yum install again and clearly got a renewed digium-current and the installation worked.

[color=#0000FF]# yum -y install asterisk18
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: centos.corenetworks.net
  • extras: mirror.metrocast.net
  • updates: centos.mirrors.tds.net
    asterisk-current | 1.1 kB 00:00
    base | 1.1 kB 00:00
    digium-current | 1.1 kB 00:00
    digium-current/primary | 37 kB 00:00
    digium-current 290/290
    extras | 2.1 kB 00:00
    updates | 1.9 kB 00:00
    updates/primary_db | 171 kB 00:00
    Setting up Install Process

    Installing : asterisk18-dahdi 19/20
    Installing : asterisk18 20/20

Installed:
asterisk18.x86_64 0:1.8.6.0-1_centos5

Dependency Installed:
asterisk-sounds-core-en-gsm.noarch 0:1.4.21-1_centos5
asterisk18-core.x86_64 0:1.8.6.0-1_centos5
asterisk18-dahdi.x86_64 0:1.8.6.0-1_centos5
asterisk18-doc.x86_64 0:1.8.6.0-1_centos5
asterisk18-voicemail.x86_64 0:1.8.6.0-1_centos5
dahdi-firmware.noarch 0:2.0.3-1_centos5
dahdi-firmware-hx8.noarch 0:2.06-1_centos5
dahdi-firmware-oct6114-064.noarch 0:1.05.01-1_centos5
dahdi-firmware-oct6114-128.noarch 0:1.05.01-1_centos5
dahdi-firmware-tc400m.noarch 0:MR6.12-1_centos5
dahdi-firmware-vpmoct032.noarch 0:1.11.0-1_centos5
dahdi-linux.x86_64 0:2.5.0.1-1_centos5
kmod-dahdi-linux.x86_64 0:2.5.0.1-1_centos5.2.6.18_274.3.1.el5
kmod-dahdi-linux-fwload-vpmadt032.x86_64 0:2.5.0.1-1_centos5.2.6.18_274.3.1.el5
libopenr2.x86_64 0:1.2.0-1_centos5
libpri.x86_64 0:1.4.11.5-1_centos5
libss7.x86_64 0:1.0.2-1_centos5
libtonezone.x86_64 0:2.5.0.1-1_centos5
yum-kmod.noarch 0:1.1.16-16.el5.centos

Complete!

[/color]

All is well. Thanks to the folks who take care of that repository.

Cedric


#4

When all else fails, you can just compile DAHDI against your current kernel.

You will need the current kernel sources installed and the appropriate symbolic links if they havent been created.

Cheers
Chris