Dahdi Installation Problem


Operating System : CentOS 5.6
Asterisk : 1.8.5

I am trying to install Asterisk in my CentOS system. When I am trying to install Dahdi source, I am getting the below errors:

Followed procedure to install:

wget downloads.asterisk.org/pub/telep … 4.1.tar.gz

tar zxvf dahdi-linux-complete-

cd dahdi-linux-complete-

make all

Error Message:

make -C linux all
make[1]: Entering directory /usr/src/asterisk/dahdi-linux-complete-' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/usr/src/asterisk/dahdi-linux-complete-’
make[2]: Leaving directory /usr/src/asterisk/dahdi-linux-complete-' You do not appear to have the sources for the 2.6.18-164.15.1.el5xen kernel installed. make[1]: *** [modules] Error 1 make[1]: Leaving directory/usr/src/asterisk/dahdi-linux-complete-’
make: *** [all] Error 2

How to resolve the above error?

Thanks in advance.


You need the kernel -devel package for the running kernel version.


As you said, I tried to install kernel-devel package as below and it is saying “No package kernel-devel available”:

yum install kernel-devel

Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

  • addons: mirror.trouble-free.net
  • base: mirror.umoss.org
  • extras: mirrors.netdna.com
  • rpmforge: apt.sw.be
  • updates: mirror.ash.fastserv.com
    addons | 951 B 00:00
    base | 1.1 kB 00:00
    extras | 2.1 kB 00:00
    rpmforge | 975 B 00:00
    updates | 1.9 kB 00:00
    Excluding Packages from CentOS-5 - Addons
    Excluding Packages from CentOS-5 - Base
    Excluding Packages from CentOS-5 - Updates
    Setting up Install Process
    No package kernel-devel available.
    Nothing to do

Below is the output by running the below commands:

rpm -qa |grep kernel


uname -r


What I have to do now?

Thanks in advance.


You need to install the version for your kernel. You appear to have a version for a more recent kernel. Either upgrade your kernel to match, or force the version number on the yum install.

As must yum repositories don’t carry many old versions, if you want to stay with the current kernel, you may need to source the RPM from elsewhere. If updating the kernel, make sure that you set the bootstrap to load that version.


Thanks for your reply. I understand and can you tell me how to do this?


It’s too long since I did it to remember the details.

Useless to degrade the kernel.

Will not work wih centos 5.6 at all. I have tried all the way and didn work.
At last i insalled centos 5.5 and working perfect. asterisk 1.8.5

Works for me. CentOS 5.6 + dahdi-linux-complete- + asterisk-
kernel: 2.6.18-238.19.1.el5xen and 2.6.18-238.19.1.el5

I suspect the original posters problem was that after he did a yum update which caused a new kernel to be installed, he had not rebooted to put that kernel into effect.

At least that is what I was able to duplicate under my test environment.

Yum install kernel-PAE-devel kernel-devel


you just put yum install kernel-PAE-devel kernel-devel

and after you must reboot