X100P that used to work won't work with new installation

I just recently upgraded my entire box and started over from scratch using Slackware 12.1. Previously I’d been using asterisk 1.4.19. I have a X100P FXO card that Zaptel used to work with perfectly fine.

Now I’m trying to use the latest versions of everything (asterisk and zaptel 1.4.11) and I can’t get my fxo channel to work.

Compiling and installing zaptel went without problems. When I modprobe the wcfxo driver, I get NOTHING in the system log. (Previously I would get notice that the Wildcard X100P was found in my syslog.) ztcfg reports NOTHING, if I run it with -v I get 0 channels to configure. However, ztscan finds my card and prints its information just fine. In fact, loading the driver causes a “1” file to appear in /dev/zap but it is unusable by Asterisk (no such device or address). lspci also finds and prints the card, and even indicates the wcfxo driver is connected to it. However, the card still will not function in Asterisk.

Here is the output of ztscan

[1] active=yes alarms=UNCONFIGURED description=Wildcard X100P Board 1 name=WCFXO/0 manufacturer=Digium devicetype=Wildcard X100P location=PCI Bus 01 Slot 09 basechan=1 totchans=1 irq=11 type=analog port=1,FXO

here is lspci output for the fxo card

01:08.0 Communication controller: Motorola Wildcard X100P Subsystem: Efar Microsystems Unknown device 0000 Flags: bus master, medium devsel, latency 64, IRQ 11 I/O ports at d400 [size=256] Memory at ff8fe000 (32-bit, non-prefetchable) [size=4K] Capabilities: [40] Power Management version 2 Kernel driver in use: wcfxo Kernel modules: wcfxo

Asterisk trying to start up zap

== Parsing '/etc/asterisk/zapata.conf': Found [Jun 9 14:15:46] WARNING[24230]: chan_zap.c:905 zt_open: Unable to specify channel 1: No such device or address [Jun 9 14:15:46] ERROR[24230]: chan_zap.c:7218 mkintf: Unable to open channel 1 : No such device or address here = 0, tmp->channel = 1, channel = 1 [Jun 9 14:15:46] ERROR[24230]: chan_zap.c:10593 build_channels: Unable to register channel '1'

This card worked without any problems on my previous installation.

What am I doing wrong? How can I get this card working again?


Heh, just got help with it, that UNCONFIGURED was the problem, and a killed klogd was the reason I wasn’t seeing anything in syslog. For others who have this problem:


generates the configuration needed. Then zttool should show OK. After that an Asterisk restart and all is good!

Don’t remember having to do this with my old setup, but hey, it works.