FXO woes

Hello all:

I have a new install with Asterisk V 1.4.13, zaptel V 1.4.6 and libpri V 1.4.2 on a CentOS V 5.0 Linux and the following hardware Linksys SPA3102, Linksys PAP2T-NA, X100P.com X100P FXO PCI cards x 2, and one X100P.com S100-FX.

I have the FXS side working fine. I can attach an analog phone to the S100-FX, the SPA3102 or the first port of the PAP2T and call between them or to SIP or iax2 soft phones.

But I cannot configure the FXO side of things. I don’t care if I use the SPA3102 or one of the X100Ps at the moment as I only have one PSTN line, but that will change.

I would greatly appreciate it if somebody would do a sanity check on my config files or suggest some diagnostic steps.

If you have a very basic set of files that works with any combination of this equipment, I would like to see them.

Thank you: John Turnbull

Below are some diagnostic messages and my conf files:

I can see a Wildcard FXO: Wildcard X100P in dmesg
zttools show an: OK Wildcard X100P Board 1
lspci finds: 00:0f.0 Communication controller: Motorola Wildcard X100P
lsmod show the following relevant things:
wctdm 37184 0
wctdm24xxp 103616 0
wcte11xp 26656 0
wct1xxp 17184 0
wcte12xp 37696 0
wct4xxp 298048 0
zaptel 187428 12 zttranscode,wcusb,wctdm,wctdm24xxp,
ztcfg -vv shows:
Zaptel Version: 1.4.6
Echo Canceller: MG2

 Channel map:

 Channel 01: FXS Kewlstart (Default) (Slaves: 01)

 1 channels to configure.

So that might be the problem with the Z100P. How do I fix this?


My /etc/zaptel.conf:


My /etc/asterisk/zapata.conf:
channel => 1


My /etc/asterisk/sip.conf:

[1000 ; X-Lite phone on D610

[1001] ; ZoIPer SIP on D610

[1005] ; Linksys SPA3102 phone type=friend
; this phone can call in and out

[1006] ; Linksys PAP2T phone #1 Exten. 1006

[1007] ; linksys Pap2T phone #2 Exten. 1007
; This is bust, and I don’t know why


My /etc/asterisk/iax.conf


[1002] ; ZoIPer iax2 phone on D610

[1010] ; The extension for the S100-FX phone
; peercontext=default ; from the X100P.com website. No idea of function


My /etc/asterisk/extensions.conf




exten => s,1,Verbose(1|Unrouted call handler)
exten => s,n,Answer()
exten => s,n,Wait()
exten => s,n,Playback(tt-weasels)
exten => s,n,Hangup()


exten => s,1,Wait()
exten => s,n,Answer()
exten => s,n,Playback(T-to-leave-msg)
exten => s,n,Verbose(1|Incoming call from PSTN)
exten => s,n,Hangup()

exten => s,1,Answer()
exten => s,n,Wait()
exten => s,n,Playback(why-no-answer-mystery)

exten => 500,1,Verbose(1|Have 500 say something)
exten => 500,n,Playback(tt-allbusy)
exten => 500,n,Verbose(1|Echo test application)
exten => 500,n,Echo()
exten => 500,n,Hangup()

exten => 1000,1,Verbose(1|Somebody called 1000, X-Lite SIP on D610)
exten => 1000,n,Playback(silence/2) ; 2 sec. silence to sync phones & sound
exten => 1000,n,Dial(SIP/1000,10)
exten => 1000,n,Hangup()

exten => 1001,1,Verbose(1|Someone called 1001, ZoIPer SIP on D610)
exten => 1001,n,Playback(silence/2)
exten => 1001,n,Dial(SIP/1001,10)
exten => 1001,n,Hangup()

exten => 1002,1,Verbose(1|somebody called 1002, ZoIPer iax2 on D610)
exten => 1002,n,Playback(silence/2)
exten => 1002,n,Dial(IAX2/1001,10)
exten => 1002,n,Hangup()

; extension 1003 does not work
exten => 1003,1,Verbose(1|Forced call to weather on PSTN with X100P)
;exten => 1003,n,Wait(1.5)
exten => 1003,n,Playback(silence/2)
exten => 1003,n,Playback(moo2)
exten => 1003,n,Dial(Zap/1/6139983439)
exten => 1003,n,Playback(vm-nobodyavail)
exten => 1003,n,Hangup()

exten => 1004,1,Verbose(1|Ring a phone connected to IAX2 S100-FX) ;
exten => 1004,n,Playback(silence/2)
exten => 1004,n,Dial(IAX2/1010,10)
exten => 1004,n,Wait(1.5)
exten => 1004,n,Playback(enter-ext-of-person)
exten => 1004,n,Wait(1.5) ;
exten => 1004,n,Hangup()

exten => 1005,1,Verbose(1|Ring a phone connected to SIP SPA3102)
exten => 1005,n,Playback(silence/2)
exten => 1005,n,Dial(SIP/1005,10)
exten => 1005,n,Wait(1.5)
exten => 1005,n,Playback(weather)
exten => 1005,n,Hangup()

exten => 1006,1,Verbose(1|somebody called 1006, PAP2T SIP phone #1)
exten => 1006,n,Playback(silence/2)
exten => 1006,n,Dial(SIP/1006,10)
exten => 1006,n,Hangup()

; This does not work either, but not high importance
exten => 1007,1,Verbose(1|somebody called 1007, PAP2T SIP phone #2)
exten => 1007,n,Playback(silence/2)
exten => 1007,n,Dail(SIP/1007,10)
exten => 1007,n,Hangup()

exten => 1010,1,Verbose(1|Sombody called the S100-FX on 1010)
exten => 1010,n,Playback(touchtone2)
exten => 1010,n,Hangup() ;

include => internal

dont forget fxs using fxo signalling

i think in your extensions.conf in the globals context you need

the Zap/g0 is the group setup in your zapata.conf

im pretty tired so someone correct me if im wrong


Thank you for your reply. I will try this when I get home from work. I had not noticed any mention of needing to configure the trunk variables in *TFOT Second Ed.

For clarification: Will I need to modify my Dial() instruction to reflect the new name of the Zap channel from

exten => 1003,n,Dial(Zap/1/6139983439)

to something like

exten => 1003,n,Dial(Zap/g0/6139983439)

Or am I missing the boat here?

Are these changes likely to fix the problem I saw with ztcfg -vv

1 channels to configure.
Does this show that the card is not fully recognized?

I still do not have a good handle on how the different secions in each conf file interact.

Thank you again: John Turnbull

no you will still do Zap/1 (1 being the channel number)

i would think that “1 channel to configure error” would be in zaptel.conf or zapata.conf
Im just an average asterisk programmer tho. Ill compare some of my live Asterisk config files to what you have posted and see anything else that may be wrong…

I try to keep notes/writeups of each config files because simple things will bite you in the butt when you have already solved the problem before and forgot it :smiley: And I have a bad memory…

I DO know that i put in a openvox fxs/fxo card and fought with it forever, and was told that i did it all correctly except i never did a RESTART NOW, i kept doing RELOAD which doesnt do as much as restarting the asterisk server…u might try that just for the hell of it…

Thank you for that clarification on the Dial() command.

I have added your changes to my extensions.conf and tried out the RESTART NOW, but still get the ‘1 channels to configure.’ error message with ztcfg -vv. I agree, there must be something wrong with either my /etc/zaptel.conf or my /etc/asterisk/zapata.conf files, but I have checked them against *TFOT 2nd. Ed.

Thank you again and if you get the time please take another look at my files - I just ordered a second PSTN line, so I am committed to Asterisk.

when you do ztcfg -vv and it is working properly it should say this if you got 1 FXO(FXS SIGNALING) module and 3 FXS(FXO SIGNALING) modules:

Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

4 channels configured.

My zaptel.conf:

Global data

loadzone = us
defaultzone = us


My zapata.conf:

rxwink=300 ; Atlas seems to use long (250ms) winks





channel => 1

channel => 2,3,4


;To Telco Lines
exten => _6.,1,Dial(Zap/3/${EXTEN:1},60,rt)

I think will probably get it now that i have posted these config files.
I would keep doing the ‘restart now’ at the cli while your testing this, then do the ztcfg -vv to see if its up. I think you can also check on your card and see if the lights are lit up on it for each port.

i read that asterisk book to, it gave a basic understanding of how asterisk works, but as far as configuring a real asterisk throw it out the window because it did not help me. I pieced my stuff together from wiki’s and tutorial websites, and with help on this forum. I keep notes on each subject of stuff that you actually need and works that i have test (example i have a word doc called “Call Parking”)

seems to work good for me hope this helps u

put your stuff in the same order as mine too, like your zaptel.conf file put the “loadzone and defaultzone” above your fxs/fxo channels.

i know some things have to be in order and mine is a working system so i would follow its structure.

one thing i noticed, maybe just a typo, is in your zapata.conf file, you signalling is fxs_kse where it should be fxs_ks


Good eye there. Yes it is a typo, but since it was a cut and paste directly from a ‘cat’ of the file, the typo is in the file.

I will correct that as soon as I get home.

Fortunatly ssh is blocked by our work IT department or I would never get any real work done here. Now, I could get around that. . . No, no, John. Don’t even think those thoughts.

Thank you: John Turnbull


I moved all my config files aside and copied and pasted your back in, with the exception that I changed:



: fxoks=1
because I am useing a single ported FXO card from X100P.com called a X100P FXO PCI Special Edition.

I then did a:

service asterisk stop
service zaptel stop
service zaptel start
service asterick start

I am still getting the same ‘1 channels to configure.’ error message with ztcfg -vv.

BTW, this is on two different machines with two different FXO cards, so it may be that these cards are unconfigurable under Asterisk V 1.4.x.

Your comment on the ‘Asterisk The Future of Telephony’ is on the mark. It comes accross as a $40 adertisment of all the cool stuff you can do with Asterisk, but not quite clear enough on how you would configure it.

I am more than willing to do my homework, but I seem to have been missing some resources. Clearly,I know about the forms, but where is the wiki and tutorial website?

Thank you again.

the wiki is voip-info.org very good site

try stopping all services, then doing ztcfg -vv then starting again. see if that helps. I used to use an X100P, but the echo was so bad i replaced it with a TDM400P, which now has 4 fxo ports on it. If you are wanting a machine that works, and works well, i would recommend dumping the x100p and replace it with a tdm card.



I knew that the X100P cards are not up to much, but I also understood that Asterisk is difficult to set up, so this is a proof of concept before investing heavily.

That is what I did with MythTV. Started with a cheap tuner and a junker computer and it worked. I now have two good tuners and 1TB RAID1 on a semi-junker and it works a peach. Family loves it, so I using the sane strategy with Asterisk.

I understand that the Linksys SPA3102 is not bad, but I am having difficulty with the FXO side of it too.

I understand the train of thought and did the same thing myself, but have since thrown the card out, I can’t be bothered to sell such a piece of garbage.

I don’t have the SPA3102, so i can’t comment on it.

If you managed to get MythTV running without something like mythdora, or knopmyth then asterisk shouldn’t be that hard. It does work, it works amazingly well, and I would go straight to the TDM card

also remember how the config files work. /etc/zaptel.conf is for the low level hardware of the FX* cards. get that to work without asterisk running, then configure /etc/asterisk/zapata.conf. That is the asterisk specific configuration file for the hardware.

Anyways, i should get back to work

Off topic, but it is MythTV running on Ubuntu 7.04. I cheated and used the Ubuntu .deb packages. I also played with MythDora, but this box does other tasks as well, so I wanted a more generalized distro.

hey john can you give us an update on if you got the card to work or not?


Hi all and hello Custom GT:

Yes, time for an update and an editorial:

In short, no I have not gotten the card working yet. I did briefly clear the ‘1 channel to configure’ error message with ztcfg –vvv, but it came back on the next boot. I have done quite extensive google searches and have found several independent sites that would indicate that the configuration files are fine. The advice is all very strange: Wiggle the card; reload load modules in specific – but not consistent - orders, try different slots. . . Yes if I had documented all the weird steps I took to get the single success, I could have added to the body of mythology, but my configuration promptly failed. I have yet to find anybody that is using this product in production – but I never intended to. I planned to just run up a quick demo box and test out Asterisk before jumping in.

So I have tried fully unloading the modules with rmmodprob and modprobe –r (I think that’s what it was) and reinstalled the modules. No go.

Now the Editorial:

Keywords: X100P.com, X100P FXO PCI Special Edition, S100-FX Asterisk << google, look here.

These cards are the X100P.com ‘Special Edition’ that are being flogged on EBay and directly from the Z100P.com site as Asterisk compatible cards. The downloadable ‘manual’ is a single web page with no troubleshooting advise.

I purchased two of the FXO cards as I have two PSTN lines, and have tried both of them on two different machines (with different motherboards), re-written the configuration files from scratch, tried them in different PCI slots and I have turned off all the unneeded peripheral devices (floppy drive; serial, parallel, and USB ports; and sound card) checked for IRQ conflicts with lspci –r and these cards will not configure. I think they are just flaky and golly, what if I actually wanted to use a USB device on this computer – like a keyboard. . .

Now they are nice looking cards but they have no capacitors. That is strange as capacitors are needed in almost all digital devices to clean up the power rails and prevent ringing. To add insult to injury, I had ordered their S100-FX FXS box at the same time (Oct 7th and it is now Nov. 22nd). The first one was DOA. It took about a week of emails to convince the good people at X100P.com that it was dead and they eventually sent me a new one, by UPS rather than postal service as I had requested, so I got to pay a brokerage fee. The second one worked just fine with the existing .conf files, so the first was bust! Now I get to mail back the first one at my expense or they’ll undoubtedly bill me.

These people have a fine reputation on EBay, but customers tend to submit EBay references shortly after a product arrives, not a month and a half later when they still cannot configure them. So the EBay reputation just tells you that they send out stuff promptly – not whether it works or not.

Now I did email them two weeks ago and last Tuesday they requested that I send them my configuration files. I copied and pasted them out of this posting and sent it off. Yesterday, at the one week mark, I wrote back and asked when I might expect some troubleshooting help and have received no reply.

Now I may have just been unlucky, but I seem to have received three duds and one, currently, working product. To anybody looking to experiment with Asterisk cheaply, the X100P.com products look like a bargain, but be forewarned: you might be climbing aboard a Gerbil Wheel that’s not going anywhere.

In the meantime I purchased a Linksys SPA3102 FXO/FXS box and a PAP2T-NA 2 x FXS box. They arrived in days and the FXS bits are working fine. Still having problems with the FXO side, but I attribute that to having not spent much time on them. The Linksys documentation is worthless as it pertains to Asterisk, but I understand that people are getting the SPA3102 FXOs working. I just haven’t yet. I own the Asterisk: The Future of Telephony, 2nd edition and Asterisk for Dummies (just yesterday and only covers up to Asterisk V1.2). Neither are helpful on the FXO side of the SPA3102. I have also pre-ordered the Asterisk Essentials: A Practical Guide to Open Source Voice Over IP which is late in printing.

BTW: The Linksys package is 3 FXSs and one FXO or about $10 CDN less than the X100P kit – before paying brokerage fees and return shipping. So ‘picks your choose’. I would be thrilled to hear from anybody that has these working for any length of time, echoing or not!

All that being said, I am still open to troubleshooting these cards and would appreciate any help with the SPA3102.

Thank you. John T

You have learned alot about it I see :smile: Alot more then I know, ive never had to go through all that. I dont know enough to help out anymore. I would suggest returning them if you can.
If your still just wanting to test you can get some openvox cards for cheap, Ive worked with a few of them they are decent for non-important installs and testing. Id go digium for production and more important stuff.

Thanks for posting the editorial it will help someone in the future!

Hi CustomGT:

Thank you for your help to date.

If X100P.com does generally have good products, I am still willing to work with them. As I said, perhaps I was just amazingly unlucky, but if they remain unresponsive, I guess I’ll just post my editorial on a different Asterisk centric forum each week until I hear from them.

If they advertise as Asterisk compatible and the examples on the web page do not work and they are unresponsive to customer inquiries, people getting started with Asterisk may need to know.

Anybody with different experiences, please jump right in.

John T

I have the same issue with a TDM card…

Zaptel Version: 1.4.6
Echo Canceller: MG2

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

4 channels to configure.

Got me beat…

I have and continue to have the same issue namely a “1 channels to configure” message on my TDM card from a ztcfg -vv. But, it is all working fine! Basically the message seems to be a minor bug but, otherwise a non-issue (at least in my case.)

My server (Asterisk 1.4.4) and zaptel (1.4.6) on CentOS 4.5 are working perfectly despite my continuing to get the “1 channels to configure” message.

When I run “core show channeltype Zap” I get “Device State: no” too. But, again it is all working. The RJ-12 was a bit of a tight fit and I had to really press it in to get it to click but, that was my only problem with the card.

Again, I suspect that the message may be a minor bug. I hope this helps.