Voicemail not working with new 1.8.9

I just got Asterisk 1.8.9 working with my phones (my 1.4 server died)

I loaded my v1.4 config files, and the phones came up. But when a phone is not answered, I receive:
Auto fallthrough, channel ‘SIP/pcssip-00005’ status in ‘NOANSWER’

How do I debug this error? Did I fail to properly compile the voice mail module? Am I missing some sound files? How can I figure out my problem?

Thanks much,

core set verbose 5

then post your cli output, use this command module show like voicemail to verify if app_voicemail.so has been loaded. if module has been loaded output should be :

app_voicemail.so Comedian Mail (Voicemail System) 0 Running core

Just as an aside, Asterisk 1.8 is no longer supported. In fact, 1.8.9 itself is pretty old even within the 1.8 branch, the final release of Asterisk 1.8 being

I’d highly recommend going to a supported branch of Asterisk.

1 Like

module show like voicemail - showed Comedian mail loaded

The CLI output is attached.

The phone rings and voice menus appear to function properly. The voicemail command seems to work properly, and takes the ,u parm to speak the “unavailable” words and numbers.

But instead of going into record mode and saving a voice mail, the line hangs up.

I’ve been unable to find any debugging info to help me determine the problem.

The CLI only shows “Auto fallthrough”, and I haven’t been able to find out what that means.

Here is a subset of the CLI output:

Asterisk, Copyright © 1999 - 2011 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: == Found
[0;37m[1;30m == [0mParsing ‘/etc/asterisk/extconfig.conf’: [1;30m == [0mFound
[0mConnected to Asterisk currently running on NBC15d (pid = 1579)
[0KVerbosity is at least 6

; Call Connected
; Voice menus working, phone ringing

[0K – Executing [s@PCS-VM-6012:3] [1;36mBackGround[0m("[1;35mSIP/pcssip-00000004[0m", “[1;35m/var/lib/asterisk/sounds/record/PCS6012e[0m”) in new stack

[0K == Extension Changed 701[default] new state Idle for Notify User 601

[0K – <SIP/pcssip-00000004> Playing ‘/var/lib/asterisk/sounds/record/PCS6012.slin’ (language ‘en’)

[0K – Executing [1@PCS-VM-6012:1] [1;36mLog[0m("[1;35mSIP/pcssip-00000004[0m", “[1;35mNOTICE, PCS-VM-6012, CallerID: “Cell Phone CA” <6193257308>, Channel: SIP/perfectcircle_SDsip-00000004, Context: , Exten: 1e[0m”) in new stack

[0K[Sep 13 21:54:54] [1;33mNOTICE[0m[12532]: [1;37mExt. 1[0m:[1;37m1[0m [1;37m@ PCS-VM-6012[0m: PCS-VM-6012, CallerID: “Cell Phone CA” <6193257308>, Channel: SIP/perfectcircle_SDsip-00000004, Context: , Exten: 1
– Executing [1@PCS-VM-6012:2] [1;36mVoiceMail[0m("[1;35mSIP/pcssip-00000004[0m", “[1;35m601,u[0m”) in new stack

[0K – <SIP/pcssip-00000004> Playing ‘vm-theperson.gsm’ (language ‘en’)

[0K – <SIP/pcssip-00000004> Playing ‘digits/6.gsm’ (language ‘en’)

[0K – <SIP/pcssip-00000004> Playing ‘digits/0.gsm’ (language ‘en’)

[0K – <SIP/pcssip-00000004> Playing ‘digits/1.gsm’ (language ‘en’)

[0K – <SIP/pcssip-00000004> Playing ‘vm-isunavail.gsm’ (language ‘en’)

[0K – Auto fallthrough, channel ‘SIP/pcssip-00000004’ status is ‘NOANSWER’

; plays voice main message, then disconnects without recording the voicemail

[0K == End MixMonitor Recording SIP/perfectcircle_SDsip-00000004

[0K == Client from, failed to authenticate in 30 seconds

[0K == Connect attempt from ‘’ unable to authenticate

Disconnected from Asterisk server
Executing last minute cleanups

Was the 1.4 box using MySQL or ODBC to store the voicemail messages? If so, maybe you don’t have ODBC_VOICEMAIL compiled in 1.8, or the user/password for the database is incorrect, or the voicemail users table wasn’t copied over. It looks like we’re missing some logging, if it’s stored in the filesystem, maybe your asterisk user account doesn’t have rights to /var/spool/asterisk/.

I am also facing same issue but with one difference i will post it the next day. after i get my mobile

Thanks much for the reply, this is making me Crazy!

I thought you had it with the permissions for /var/spool/asterisk. I tried changing asterisk to run under user asterisk and group asterisk, but my phones stopped working, and I could not see why. So I changed the users back and now the asterisk processes are run under root.

I changed the permissions on directory /var/spool/voicemail to chmod 777, but no change. I realized that wasn’t it, as the directory voicemail has under it the directories default, then 601 (my extension) and INBOX. Since the directory 601 was created, I assume the directory permissions are OK.

I tried to make asterisk run in user asterisk and group asterisk.
I changed /etc/sysconfig/asterisk (specified AST_USER and AST_GROUP)
I changed /etc/init.d/asterisk (uncommented AST_USER and AST_GROUP)
After a reboot my phones didn’t work, so I changed those back, and at least my phones came back.

How can I get enough debug information to figure out what is not working? I’ve pored through the asterisk documentation, and it was no help. You would think they would have a sections that is “these are all the things you need to make voice mail work”. It seems the required elements are scattered around the documentation in a fairly hap-hazard fashion. If I know what I want, I can find most of the parameters. But if I need an overview and how the config file relate to each other, the documentation is lacking.

Thanks is advance for your assistance,

Please post the relevant config segments and dialplan. Since you’re running asterisk as root, there shouldn’t be any permission problems.

1 Like