Voicemail; cannot have duplicate mailbox #s in multiple contexts

Asterisk v13.1.0

When I tried the following (straight from sample file) in voicemail.conf:

1234 => 4242,Example Mailbox,root@localhost

1234 => 5678,Company2 User,root@localhost

I see the following at the Asterisk CLI:

pbx0*CLI> voicemail show users
Context    Mbox  User                      Zone       NewMsg
default    1234  Example Mailbox                           0
1 voicemail users configured.

Asterisk doesn’t appear to be able to parse multiple mailboxes of the same number even if they’re in different contexts. If I change either of the mailbox numbers and for a “voicemail reload”, they both show up.

Is this a bug? Should I be able to re-use mailbox numbers if they’re in separate contexts?

Didn’t read the question carefully enough.

That’s frustrating… not clear from the sample configs where it appears you can have multiple mailboxes of the same number in separate contexts.

If you can’t do this, what is the best practice for multi-tenant VM? Should I pre-prend each mailbox with tenant name? I believe this would break the VoiceMailMain() application.

Apologies. I was thinking about dialplan contexts and replying too late at night.

Ah… anyone else? Would love to hear your experiences on multi-tenant voicemail.

It works for me:

*CLI> voicemail show users 
Context    Mbox  User                      Zone       NewMsg
default    1000  Example Mailbox                           0
default    1234  Okay Okay                                 0
other      1234  Company2 User                             0
tacos      01234 John Doe                                  0
bananas    1234  Meh                                       0
squirrels  1234  Tacos                                     0
6 voicemail users configured.

Have you looked at the log when app_voicemail loads to see if it provides any information? I’m also testing on Asterisk 13 branch, which would be near the latest release.

1 Like

I have. I see nothing unusual apart from the standard message saying it is parsing voicemail.conf. I’ve tried increasing the verbosity and debug level, but still don’t see any errors.

Can anyone point me to the proper way to see what is happening when I issue a voicemail reload?

Have you updated to the latest version just in case? (Chasing bugs that have already been fixed occurs a lot). Have you provided the COMPLETE voicemail.conf you are using? You can also try adding “debug” to the console output in logger.conf and seeing if that yields any additional information from app_voicemail.

1 Like

Thanks for your help on this. I configured a new VPS with Ubuntu 18.04, installed Asterisk and tested my configs. Seems the newer version of Asterisk is more vebose, and the CLI gave me a warning pointing out that having searchcontexts=yes means you can’t have duplicate mailboxes.

Problem fixed!