Very basic Asterisk configuration question (re: Sipura 3000)

[EDIT] I’ve rewritten this, since I’ve figured out my first problem but now I have a new problem…

Incoming calls from my Sipura 3000 don’t seem to be correctly routing to Asterisk (or something?)

Here is my Asterisk configuration for my incoming PSTN line:


Inside of extensions.conf, I have this:

exten => s,1,Answer( )
exten => s,2,Background(enter-ext-of-person)

When I call my PSTN line, my Sipura 3000 seems to successfully answer it because the line rings once, but then immediately switches to a second dial tone. Shouldn’t my incoming call be answered and then have “enter-ext-of-person” played to them?

What could be causing this?

you need to go into the advanced settings of the PSTN line and put in Dial Plan 2 this without the quotes: “(S0<:s@>)”

The IP address above should be your Asterisk server.

Then choose “2” in the input box called “PSTN Caller Default DP:”

The above instructions along with the guide found below should get things working: … &Itemid=28