Asterisk + Sipura NAT Issues


#1

Hi all,

I’m having issues getting either of my two Sipura VoIP devices (the SPA-2000 and a SPA-941 phone) working behind my NAT, trying to connect them to my Asterisk SIP server (which is on the internet, not behind the NAT). I’ve tried just about every combination of settings on the Sipuras, including enabling NAT Mapping and NAT Keep Alive, and also setting the Substitute VIA Addr/Ext IP to my WAN IP address. I’ve set nat=yes for the extension on Asterisk, and tried various configurations with my NAT router, including setting the Sipura as my DMZ device (so all traffic should theoretically go straight through), as well as forwarding UDP ports 5060, 5061 and 16384-16482.

The problem is quite an odd one - it registers fine on the phone, and can make outgoing calls - but I can’t make incoming calls to the phone from the Asterisk system. Whenever I try, it rings for about half a second, before going onto the voicemail, telling me that the extension’s unavailable.

Any ideas would be great, as I’d love to be able to get these working!

Thanks,
Giancarlo


#2

Does sip show peers list an IP address for the phones? What does the CLI show when the call fails?


#3

Thanks for your response! Yep, the sip show peers command shows the phone as connected, with its external IP address and port, and says NAT is N (I assume that means that NAT is off). When the call fails - this is what is printed, looks like a clue:

Called 121
Got SIP response 488 “Not Acceptable Here” back from 59.167.xx.xxx
SIP/121-78c2 is circuit-busy

Any ideas?
Giancarlo


#4

Check your codec settings.

488 is only caused if you (exlusivly) allowing a codec which the other side isnt supporting.

Make sure, your Sipura and asterisk are using the same codec.

Eg.
disallow=all
allow=ulaw
allow=alaw
etc

Remember that G729 is NOT a free codec, its patended and therefore not free, therefore NOT supported by asterisk “out of the box”.

Richard