Unknown for CID

I have a SIP trunk with a Cudatel and a Asterisk, so previously the callerID name was showing test as the number, and still passing the correct name through, so I told me support on the Asterisk server to remove the fromuser field, and not the calling number is showing unknown, but the name of the caller is still showing, any ideas on how to get the caller number to display?

The default behaviour is to forward the incoming caller ID to the outgoing side, so you are going to have to show us what you have done to break that.

Are you sure you are actually receiving caller ID?

Sorry David let me clarify, when they call me with the Asterisk I receive their name and unknown as the number, when I call them they receive the username (which I will work with Barracuda on).

You are probably not receiving caller ID. trust_rpid may help if you are receiving it, but not in the From header.

If you have to use fromuser with the remote device, the sendrpid parameter may help, if it accepts one of the options. However a good ITSP will not accept callers IDs that you have not proved that you control.

This is the current config.


Quick question are you using FreePBX ?
and also some notes
change type from friend to peer

The parameter “username” is not the username and in most cases is
not needed at all. Check below. In later releases, it’s renamed
to “defaultuser” which is a better name, since it is used in
combination with the “defaultip” setting

use remotesecret instead of insecure invite
host has : and it should be =

canreinvite= was renamed to directmedia= in Asterisk 1.6.2 to more accurately describe what this setting does.

requirecalltoken=no trunk=yes options are not valid options on sip.conf

I’d also add that if you are going to authenticate on a local trunk you should do so both ways, by removing insecure, and possibly by adding remotesecret, unless the peer is incapable of authenticating itself. In any case, the chance that you need to make the port insecure in this situation is rather small.

As to your caller ID. Inbound, it looks like you do not have a caller ID arriving. Outbound, you could see if it accepts sendrpid=pai. Use sip debug to confirm whether and how inbound caller ID is arriving and also to confirm that your dialplan hasn’t broken the outbound caller ID.

I believe trunk=yes in sip.conf is an artefact of FreePBX. Asterisk doesn’t distinguish between trunk devices and extension devices.