Unable to register any SIP clients


#1

Ok I’ve been at this now for a couple of days and still can not get this to work nor can I find out what is wrong.

I can register my asterisk server with my service providor via SIP no problem but I am unable to register any clients with my server via SIP.

My local net is nated to the internet (like most are) and I have the system that asterisk is running on as a DMZ so all incoming connections are forwared to it. I can receive calls from my outside trunk. So SIP is working and system also works.

But when I try to get the 3CX soft phone to register from any of three diffren sorces it will not work. I have also setup a asterisk server in a VirtualBox and tried to get that to register with my asterisk server an no luck.

What is known:

  1. I have all know things setup correcly (ip address, port, username, password, softphone settings etc)
  2. all clients are timming out trying to talk to the asterisk server (softphones take forever and give up, second asterisk server says it times out)
  3. I get nothing on the asterisk server box when anything trys to register with it.
  4. This is a brand new system with Centos version 6
  5. I’m unsing a asterisk server I build from the sorce on the 1.8 trunk
  6. all other connections to the server that asterisk is running on work from from one of the PC’s that I’m trying to run the softphone one (telnet, ping, http, ftp)
  7. all outgoing connections from the server are also working (SIP, RTP, http, ftp, telnet, etc)
  8. there is nothing in the logs to say anything happend when a client trys to connect.
  9. my extensions.conf is mimal an contains
    [globals]

[general]
autofallthrough=yes

[default]

[incoming]
exten => Trunk, 1, Goto(s,1)

exten => s, 1, Noop(forwarding to ${SIP_HEADER(“To”):5:10})
exten => s, n, Goto(${SIP_HEADER(“To”):5:10}, 1)
exten => s, n, Answer()
exten => s, n, Playback(invalid)
exten => s, n, Hangup()

exten => 9722499710, 1, Answer()
exten => 9722499710, n, Playback(hello-world)
exten => 9722499710, n, Hangup()

exten => 9727918365, 1, Answer()
exten => 9727918365, n, Playback(hello-world)
exten => 9727918365, n, Hangup()

exten => 4694532100, 1, Answer()
exten => 4694532100, n, Playback(hello-world)
exten => 4694532100, n, Hangup()

[internal]
exten => 1000, 1, Dial(SIP/1000)
exten => 1001, 1, Dial(SIP/1001)
exten => 1002, 1, Dial(SIP/1002)

[phones]
include => internal
9) the sip.conf file is also minal as
[general]

register => xxxxxx:xxxxxx@?.?.?.?/Trunk
; register => xxxxxx:xxxxxx@?.?.?.?/Trunk

context=default
allowguest=no
allowoverlap=no
udpbindaddr=0.0.0.0
tcpenable=no
srvlookup=yes
nat=yes
allowsubscribe=yes
localnet=192.168.1.0/255.255.255.0
externhost=?.?:5060
sipdebug=yes
dynamic_exclude_static = no
session-expires=120
session-timers=originate
session-minse=90

[Trunk]
context=incoming
host=?.?.?.?
type=peer
nat=yes

[1000]
type=friend
host=dynamic
nat=no
context=phones
secret=abcd

please note that all the stuff for the trunks have been removed and that stuff does work so is not important as this did not even work before I added that stuff too. I have also remove my host name but that is correct as once again does work that way.

Please any help would be great. Oh I have also gotten the book Asterisk: The Definitive Guide 3rd Edition and that did not help… The only thing that I got from that and have tried is to disable SeLinux.


#2

hi,

check that there is no firewall rules (eg iptables) in your unix to block the port 5060.

can also turn on sip debug as below.
asterisk -rvvvvvv

sip set debug on

to see if there is any error during sip registration.

hope it helps.

best regards,