Trying Asterisk In The Cloud.....Not A Lot Of Luck

I have an Amazon instance of Asterisk 1.6 up and running. It is FreePBX 2.5. I configured an extension ok.
However I cannot register a softphone. I am trying 3CX and Mizu on both my Android phone and my PC.

On the Asterisk server:

[root@ip-10-2-XX-XXX asterisk]# netstat -nap | grep asterisk
tcp 0 0* LISTEN 2114/asterisk
tcp 0 0 ESTABLISHED 2114/asterisk
udp 0 0* 2114/asterisk
udp 0 0* 2114/asterisk
unix 2 [ ACC ] STREAM LISTENING 6727 2114/asterisk /var/run/asterisk/asterisk.ctl

It appears to be listening for SIP… (I’ve obfuscated the IP for obvious reasons)

I am trying to register 3CX and Mizudroid from my HTC Inspire Android phone with no luck.

I have tried the asterisk -rvvvvvvvvv
sip show settings
sip set debug on

I do not see anything happening while I tried to register a phone? I have tried registering the softphones from my home network PC, and from my Android phone using WiFi or 4G with no luck.

I can ping the server from my home network PC, and from my Android phone using WiFi or 4G.

I also tried running ‘tcpdump -i any’ from the server and did not see any packets when my softphone attempts to register.

My 4G and home DSL provider is AT&T.

Any ideas on how to further troubleshoot this?

I’d appreciate it.


You problem lies outside Asterisk.

Also note that all 1.6 versions are, at most, on security fixes only and will be fully end of life in two weeks time!

I would suggest that running a cloud version of something with the realtime constraints of VoIP is not a good idea.

Also, this is not a support forum.

I am only doing this as a learning lesson. If I could get a single SIP call to complete I would be satisfied.

And maybe you should tell all of the VoIP companies in the cloud that it’s not a good idea?

And what exactly is “Asterisk General” forum?

Of course it isn’t but this is how they make money, so they won’t listen :cry:

Why don’t you check the only sticky in this section - “Does my topic belong here?”