SIP devices not registering with Asterisk

Okay I just setup my Asterisk box and I have it on a LAN with soft and hard phones. I can’t get any SIP devices to authenticate and register with Asterisk. This is all internal and I’ve even disabled the firewall but to no avail. I’ve tried ports 5060 and 5061. I keep thinking the box itself is blocking requests from the devices and when I ran netstat looking for asterisk here is what I got:
tcp 0 0* LISTEN 7657/asterisk
tcp 0 0* LISTEN 7657/asterisk
udp 0 0* 7657/asterisk
udp 0 0* 7657/asterisk
udp 0 0* 7657/asterisk
udp 0 0* 7657/asterisk
udp 0 0* 7657/asterisk
unix 2 [ ACC ] STREAM LISTENING 23668 7657/asterisk /var/run/asterisk/asterisk.ctl

What am I missing?

Here’s the info:
CentOS 5.4

How about posting your configurations here?

Hello everybody,
I’ve met an issue very alike to this topic.

I’ve installed Asterisk 1.6.2 from source package on my openSuse 11.2.
I made samples:

and added to sip.conf:


as I have SIP hardphone on the same LAN segment.

I started asterisk:

checked that there are succesfully listening ports (UDP) for SIP and IAX:

Then I plugged into FastEthernet port on switch my IP phone and watched (by wireshark) how he tries to register: to SIP REGISTER

and there are NO SIP frames from (asterisk/openSuse).

I do not have a clue what is going on.
Why does asterisk even don’t reject (loudly via LAN) SIP REGISTER?

I’ll be glad for help. Any help, any notion or idea.

try a tail -f /var/log/asterisk/messages and see if it is rejecting your devices, have you tried asterisk -vvvvvvvvvr to see what is going on?

I cleared /var/log/asterisk/messages and started asterisk:

# rm /var/log/asterisk/messages
# touch /var/log/asterisk/messages
# /usr/sbin/asterisk
// waited while to receive a few SIP REGISTER attempts. 
# /usr/sbin/asterisk -r
CLI> core stop gracefully

Here you have SIP REGISTER attempt.
And here

Do you know any 1.6 tutorial (as 1.4 book solution has not worked for me :frowning: ) where you create from scratch (so no make samples!) simple LAN topology just with let’s say two SIP hard/softphones?
In other words just basic configuration files to let talk to each other but without all bunches of these modules config files.