Unable to install Asterisk

Hey guys, I am new to Asterisk…
When I run the command “./configure” At the end of configuration it gives the error “error .****, termcap support not found”.

I have no clue for this. What is this all about. Do I have to install something else before…

first what distro are you using, on ubuntu sudo apt-get install libncurses-devel

I got the same problem. I am using Centos 6.
I was following the youtube video about installing asterisk 11.

I had to make && make install && make config the dahdi en libpri parts. That went ok.
Then I had to do the same for the asterisk 11.

on the .configure option I got the “termcap support not found”.
I think the termcap is connected with the ncurses lib, so I went searching in that direction.

I used yum install ncurses-devel and tried again. This time it kept going.
Problem solved.

And that’s why I always recommend FreePBX… though troubleshooting is always a great tool to learn… but if you’re trying to save your time, go for FreePBX…

That assumes you don’t have to do any troubleshooting later on. People who only install from GUI packages often find they don’t understand what is really happening well enough to debug problems.

In the past, i used to be a devote of GUI (Elastix.Freepbx, Ect). But i stopped to use those products for several reasons like :

You are tied to do what the GUI allow you do to.

Very difficult to debug the any dial plan issue.

If the system start fail unexpectedly, you will have a hard time debuging your problem.

Things that are pretty simple to archived in plain Asterisk are a big headache to archived in those GUI.

and the biggest reason you never will learn how Asterisk works, until you start to write your own dial plan and configs.

Please mention which version of asterisk you are installing. Before installing from tar file , you need to install per-requisite development rpm …