Installation issue with Asterisk1.4.0


I have been trying to install Asterisk 1.4.0 for three days now to no avail.

Running on SUSE 10.1 Linux.
Expanded tar
when ran configure,

configure: error: *** termcap support not found ------> error found.
i have installed the termcap library, ran configure again. same error promted out.

Any ideal to solve this problem?

Also, when i proceed to the second “make” (make) compiles…

**** The configure script must be executed before running ‘make’.

make: *** [makeopts] Error 1

cannot to proceed to the third “make install” compilation.

I am hoping someone can assist me with the install.

thank you

it looks like the Asterisk configure script can’t find the termcap libraries it’s needing. did you install the termcap-devel package ? as a rule of thumb, it’s the -devel/-dev packages that are needed when you’re compiling Asterisk.

make will not run until the configure script completes successfully.

I had the same error with Centos,
then I’ve solved with this

yum install libtermcap libtermcap-devel newt newt-devel ncurses ncurses-devel