Unable to compile CVS-Head


#1

Hey Everyone,

I’ve been happily compiling asterisk for over a year now - but about a month ago I tried to download CVS head and compile it using the same steps as I’d normally use:

Libpri (make clean; make install)
Zaptel (make linux26; make install)
Asterisk (make clean; make install)

However, when I compile Asterisk the compilation gets stuck in a loop, constantly showing the same output (see http://pastebin.ca/21320).

I’ve searched the web for the past month for a solution for this, and asked on IRC on several occasions. However, I haven’t found a solution.

I’d really appreciate it if someone could provide some suggestions.

Thanks,

Phil.

Machine Details: Fedora Core 3, gcc-3.4.4-2.fc3, binutils-2.15.92.0.2-5.1, bison-1.875c-2.


#2

It could be worth updating your sources from the CVS repository. It’s possible that this is caused by an error in the sources that was fixed soon after.


#3

Hi WillKemp,

Thank you for your suggestion, but I’ve tried that. I’ve been checking out cvs-head every week or so, and each time the same problem occurs.

Phil.


#4

Hey Everyone,

It seems this was caused by my kernel. Compiling and installing a vanilla 2.6.12.5 kernel and then re-compiling asterisk seems to have solved the problem.

I hope posting this here will help someone in the future.

Phil.