Trying to smsq with TDM400P

I have asterisk Asterisk (Ver. 1.8.18.0) with a TDM400P card 3 PSTN line and one GSM box on my fourth channel, also I use voip innovations for dids and local termination, I’m trying to send sms with the smsq command, tried to send it throught my TDM400P and my GSM modem like this:

smsq --motx-channel=DAHDI/4-1 -d 1781111111 -m ‘hola como estas’

and I get the following response:

Connected to Asterisk 1.8.18.0 currently running on 4channels (pid = 17030)
Verbosity is at least 5
– Attempting call on DAHDI/4-1 for application SMS(0) (Retry 1)
> Channel DAHDI/4-1 was answered.
> Launching SMS(0) on DAHDI/4-1
sms argc 1 queue <0> opts <> addr <> body <>
initial delay 300ms
– Attempting call on DAHDI/4-1 for application SMS(0) (Retry 1)
– Attempting call on DAHDI/4-1 for application SMS(0) (Retry 1)
– Attempting call on DAHDI/4-1 for application SMS(0) (Retry 1)
– Attempting call on DAHDI/4-1 for application SMS(0) (Retry 1)

and dies after 11 times.

I tried throught my SIP account with voip innovatios whew they require to add the #(hash/pound) and the beginning of the destination number.

smsq --motx-channel=SIP/Voip-Innovation -d ‘#1781111111’ -m 'hola como estas’
and they say they don’t get the destination number, nor the hash key,

I have NOT modified or created anything on my extensons.conf.

Here are my questions;
1-Do I have to create anything on my extenson.conf. From what I understand I gave already the channel where I want my message to be send throught?
2-Am I adding correctly the hash sign to my outgoing number?
3-Do I have to configure anything else on my pbx?

I have been all over the place on the forum I couldn’t find any good detail nor clear explanation, must of the people sends you to voip-info.org/wiki/view/Asterisk+cmd+Sms and there is no clear explanation of what else you have to change or do to make it work.

I think would be of great use no just for me but for everyone that is lost in this matter

Thank you

I got it to dial with the smsq command and my voip-innovations SIP trunk, but I need to send the hash sign prior the number, asterisk does not recognize the hash sign at the beginning of the number how could I send the hash sign first? for example
smsq --motx-channel=SIP/Voip-innovation/#1786XXXXXXX -m ‘hola como estas’

if I send it like that does NOT send the hash sign as part of the number.

Please help

I truly don’t know why we have this forums, must of the times, people that knows ‘asterisk gurus’ never help If you read must of the post in reference to sms they send you to the voip-info.org/wiki/view/Asterisk+cmd+Sms website or the post just goes unanswered.
Great asterisk community, what a disappointment.

Thanks gurus for nothing, I will do my own research. and don’t worry when I find out how to do it I will published here for the fellows that fills like me.

I assume that once you have found the answer, you will monitor the forum and answer all similar questions in the future.

The reason you don’t get a reply is that there are very few people who volunteer to respond in these forums and of those that do, I suspect the only ones that originate SMS do that using web connections to an SMS Centre, rather than using the facilities in Asterisk.

Thanks david55 for those words of consolation, but yes I will post any findings here, that is the purpose of a forum help and be helped