Can someone help explain this?

Im stuck on this issue and have no clue what the problem is.

Im runing the latest stable version of Asterisk.
I have a static IP address assigned to my Asterisk server. I telnet to the Asterisk server and ping google so i know i have the network setup correctly.

I have a linksys SPA921 phone on ext 201 and i cant get it registered, but I can connect via softphone to ext 201, it registers fine.

Im trying to determine its not blocking port 5060, but if it was blocking port 5060 would i be able to register my softphone?

Thanks for any help!

surely someone can help me with this? Im dead in the water till i get my phone registered.

Asterisk provides a lot of debugging information. Start by doing “sip set debug on”, and seeing what is actually being sent between the phone and Asterisk.

Thanks for the info, I ended up using the CLI and I saw that it was being reported in the CLI if I tried to connect via the softphone, but not being reported in the cli if I tried to connect with the linksys phone.

This told me that the asterisk wasnt getting the request. So then I knew it was a network connection with my phone. I reset to factory defaults and everything is working again.