TFTP problem

I know asterisknow has a tftp server that comes with it. I have checked (using chkconfig) and it is up and running. However I cannot connect to the tftp server. I am assuming it is a firewall problem on the box. Since I do not know centos all that well (or linux for that matter), how can I check that port 69 is open for the tftp server through the command line?


You may need to install it first.

It is installed and started. I confirmed this with chkconfig.

chkconfig only tells you about the server, not the client.

The client is installed. I have used it previously to connect to a solarwinds tftp server. It is the basic windows tftp client.

I have a very similar problem -

  • I have installed Asterisk NOW
  • Phones are getting DHCP information correctly (from seperate box) and learning correct TFTP server address (the Asterisk box)
  • Phones can’t get anything out via TFTP - everything stops
  • Can’t find anywhere on Asterisk box where TFTP transactions are logged (some seem to think it’s in /var/log - it’s not)
  • Enabled TFTP service in section (default is OFF) under SETUP menu - no effect
  • Disabled IPTABLE service (which is a firewall I think) - no effect

Totally stuck. Any suggestions welcome.

I’ve made some progress:

Load all your files into your /tftpboot/ directory and then do this:

chmod 777 /tftpboot/*

Phone upgrade now works!

Change that to 444!

The problem will be that the files have the wrong owner.

So if the Asterisk developers are out there, the following would be really nice and helpful to others in future:

a) Make sure the TFTP service is running by default in Asterisk NOW
b) Ensure that a TFTP log is automatically turned on and sent to /var/log

Thanks guys

P.S. i am still not sure how to turn on a TFTP log - it would be really useful with troubleshooting phones. Anyone know? I’m not a Unix/Linux person at all - I’m a router person… any help appreciated.

Hi guys!

Try logging into ssh and typing chkconfig tftp on

It worked for me. I can’t confirm it will work more than a once-off… for now, that’s all I got.