TE110P LED not working

For almost three months Asteisk-1.2.6 with TE110P card connected to Channel bank is working properly. until yesterday when i tried to reconnect asterisk console with “asterisk -r” it say something like “does /var/run/asteterisk.ctl exist?”

i tried to reboot but still had the same error

before this, i use to configure my zapata.conf

another thing i have noticed the TE110P LED is not working as in the Green and Orange is Off totally

and when i type zttool it say

Alarms Span
Unconfigured Digium Wild Card TE110P T1/E1 Card 0

likewise ztcfg result is

Line 224: Cannot get number of tones for channel 24
Line 224: Cannot init tones for channel 24
(actually this error is a series until channel 24 i only write the last two lines)

i feel TE110P is destroyed, am i right?

why is this happening?

please help

The card is just three months old

does anyone have idea? please help
please please

I dont know much on T1 but i will try…

Did ANYthing else change to make it break? Did you try downloading and compiling a new version of Zaptel? Also, see if the error message changes when PRI interface is not plugged in?

i just configure my zapata.conf coz our punch down block just arrive which is intended as telco and channel bank terminal and thats it after receiving the error “does /var/run/asterisk.ctl exist?” i decided to reboot and after reboot everything is going bad…

…now i have formatted my hard drive and install with zaptel-1.2.6, libpri and asterisk- …install the driver as what i have installed before
and still i have the same problem

well the * error is because asterisk was compiled with Zaptel so no zaptel = no asterisk. the var run ctl just means * isnt running, so it cant attach a * console.

when you udpated your config, did you change /etc/zaptel.conf as well as zapata.conf?

worst case scenario you could comment out everything in zaptel/zapata.conf and then zaptel will load, and you can load *. This will get * running so voip-based stuff works…

i think it might be a /etc/zaptel.conf error… zaptel.conf sets stuff up for zaptel driver, zapata.conf sets it up for *. Both need to define mostly the same stuff. zaptel.conf err would cause the light to not light, as its not being initialized by zaptel… i think that is where your problem probably lies.

you’re going to have to look at the logs to see what’s happening. relying on the results of “asterisk -r” isn’t going to get you very far.

you need to look at the end of /var/log/asterisk/full to see why Asterisk didn’t complete loading. you need to unload and reload zaptel (‘service zaptel restart’ possibly) and look at the output of ‘dmesg’ to check the modules are being loaded correctly. then run ‘ztcfg -vvv’ and check output.

any errors or problems at this stage, there’s no point trying to start Asterisk. fix the problems first. post the messages/errors here if you’re unsure.

here is the T1 configuration of my zaptel.conf

loadzone = us
defaultzone = us
channels = 1-24

here are the result of “ztcfg -vvv”

Line 224: Cannot get number of tones for channel 1
Line 224: Cannot init tones for channel 1
Line 224: Cannot get number of tones for channel 24
Line 224: Cannot init tones for channel 24

(actually this error is a series of channel 1 until channel 24 i only write few because i cannot copy and paste the result because my asterisk server has only CLI no KDE or gnome

here are the result of “dmesg” related to TE110P wild card

hw_random hardware driver 1.0.0 loaded
Zapata Telephony Interfaces Registered on major 196
Zaptel Version: 1.2.6 Echo Canceller: KB1
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 17 (level, low) -> IRQ 193
Controller version: 24
FALC version 00000000
TE110P: Setting up global serial parameters for T1 FALC V1.2
TE110P: Successfully initialized serial bus for card
Found a Wildcard: Digium Wildcard TE110P T1/E1
input: PC Speaker
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0300140(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present

hope this info will aid solving my problem

you have a T1 line, remove the fxsks and fxoks lines, like this:

loadzone = us
defaultzone = us
channels = 1-24

make the changes above, then i would reboot again, making sure that all of your startup scripts are disabled (no automatic loading of the zaptel drivers, etc).

then do the following:

modprobe wcte11xp
ztcfg -vvv

if you are still getting the same errors, move the card to a different slot and/or try it in a different computer. if you are STILL having issues, contact digium as you may have a faulty card.

good luck.

I pulled out my card and mounted it in another box with asterisk running
but without any digium card installed…i configured zaptel.conf according to the direction above and “modprobe wcte11p” and then "ztcfg -vvv"
i got exactly the same errror from the first box which i found the card is not working.

I contacted digium thru email but until now there is no response…
I might try calling them… its really hard for me in times like this because
i live so far from Digium-US