TDM400 card, some analogs ring & some don't... Current/v


#1

Greetings,

I am currently operating a very simple configuration on a fresh install of asterisk 1.2.0b1. I have a linux host with a 2.6.13 kernel and a TDM400 PCI board installed with an FXS module on port1, and FXO module on port4 (the way it came from digium). I prefer the large gap between ports while getting used to the hardware to prevent woofing any equipment, so no problems there.

I have the simple configuration working as cited on digium’s tdm400 online documentation, and everything is working pretty much exactly as I had expected, minus one little gotcha:

Of my two analog phones, only one will physically and audibly RING when the ring signal is sent out Zap1-1 according to the console output. The phone that rings audibly also happens to be a set-top corded phone; nothing fancy, a sony IT-M602; AKA run-of-the-mill $80 consumer 2-line phone with a few features. The callerID, cdr/mysql database logging and everything else works great as well.

Then, i switch (not add, substitute completely) to a GE model 27936GE-M, which to save you any obscure lookups is a fairly run of the mill $100 consumer 2.4Ghz cordless phone. In this phone’s case, when the Zap1-1 port rings, the phone will pickup the CLID information properly, and can even pickup and communicate flawlessly, etc. The only problem is, this phone will not audibly ring !! Neither the base station nor the handset, in any configuration of defaults and [un]docked status, ringer(s) (handset/base)=1/0, 0/1, and 1/1. 0/0 not much use :wink: I’ve been searching the digium, asterisk, forums and google(rand) sites for hours and hours now and just can’t locate a cause. The REN on the GE phone is listed as “0.4B”, the Sony phone that DOES work does not have a printed ringer equivalence, oddly. I have not taken the time to measure current across the phone line during ringing as the results will not open any new t/s’ing avenues, regardless.

So, i’ve come to wonder, is the 4-pin keyed molex connector coming from my Antec PC power supply providing the needed voltages ? My PS-Molex connector is
keyed |/~1~2~3~4~| where 1=red=5v, 2=blk=gnd, 3=blk=gnd, 4=yellow=12v.

I believe i’ve exhausted all configuration options and am looking at a Current-shortage problem; however I am unable to find the simple 4-wire schematic for the tdm400’s power connectors, which is frustrating me to no end [lest i not have to write this post and fix the problem NOW!!].

Anyhow, I apologize if I’ve missed anything obvious but if I did, it wasn’t bourne of lack of effort I promise you. My spatial awareness and research skills have become horribly frayed after hours of EVERY configuration iteration I could think of.

So, a schematic, or a POSITIVE ID of the power posts on the TDM400 board, or some other sort of insight as to why I am getting sporadic results across various analog phones as to whether they audibly ring or not ? I must sleep, but due to all other functions working properly EXCEPTING audible ringing, my money is on ringing=current=s/5v/12v ???

Thanks! LOVING the asterisk software and the hardware is admirably robust as well! I plan to tout these heavily at client sites without my managers knowing I’m helping clients to save hundreds of thousands of dollars in proprietary ware… the true irony is in that which I cannot divulge, but I promise the irony is delicious…

Best Regards,
Jayson


#2

Just because I’ve seen it before… You didn’t silence the ringer, did you?

Other than that, I’m wondering if the Digium card only connects ringer voltage to a single line (either tip or ring) and the ringer of the GE phone is connected to the opposite incoming line?

Swap tip and ring going to the GE phone, (through a simple line jack) and see what happens…

Ringer voltage is defined as 85-100 volts RMS at 20Hz. Current should not be an issue, it’s in the milliamp range, and the molex connector should be able to push the needed current. If you’re getting proper ringer voltage, then your ringer should work. (Assuming there’s no cross connect issues as described above.)


#3

Stupid question (and I do tend to agree with dufus that this is probably a problem with the phone itself, not with the TDM or asterisk):
Does the ringer work when connected directly to the PSTN, not using TDM or *?


#4

dufus, bsdbigot: thanks for your time in replying and your suggestions. I went ahead and went through all the iterations again, checking the phone against the telco NI itself, and it does indeed ring it’s little heart out. Plug it back into the TDM400 FXS jack, using FXO_KS signalling (having also tried LS and GS)…and it won’t ring! I then punched down a tip/ring reversal plug into my patch panel and flipped the pair… everything still worked wonderfully EXCEPT for audible ringing from the telephone. No dice! asterisk is running with -dvvvvc and hasn’t a THING to say about the matter either. Even the message-waiting tones and everything else works on the phone(s); it’s just that the GE cordless will NOT ring audibly. Displays CLID, can pickup and transfer and dialout and everything else just dandy… but no audible ring.

I’m not sure if I mentioned it, but the GE phone has both a ringer in the base AND in the handset, and I have tried every combination possible between them; as well as repeating every combination with the handset in the cradle. I’m STUMPED, and pissed off at this phone, LOL. I think you’re both right, the ONLY thing it can be at this point is the phone; but it makes me wonder what the TDM400 itself or the driver isn’t quite doing to spec vs. the wall NI. Personally I think the phone probably just demands and exorbitant amount of juice to ring, and there is a small range between the TDM400/FXS module peak current and the Telco NI peak current; and the phone is operating within that range.
My PC power supply is only driving a modest sempron 3000, 512M ram, one ATA100 hard drive and that’s all. The supply is an Antec ‘smart power 2.0’ 450W supply. I would be stupified if the Antec supply was not providing ample power. Again, asterisk doesn’t complain about a current shortage so i’m sure the TDM400 is giving it all it’s got…
This sucks as the only clear solution at this point is to purchase a new phone, but knowing my luck i’d get another anomaly. And that’s definetely what this phone is… an anomaly. Still, I’d like to figure it out…

I saw mention of ‘boostringer’ or somesuch in reference to the wctdm module, I’m going to have a look at the zaptel source and see what’s going on in there ??

ANY other input is appreciated, this could afterall be a standardisation issue that needs to be worked out regardless, as I have seen this model of phone in MANY a ‘joe consumer’ household. Not quite the same model number and not even always the same manufacturer, but it’s definetely a template phone coming out of some large automation plant and I’m not the only one that will be impacted…

As far as asterisk configuration syntax, I promise it is all valid. It is sparse at best, and all ringing is handled by a lone Dial command in it’s most humble context. Works wonderfully on the Sony phone, but terribly on the GE/Mutant/Template-Replicant Juice-Sucker phone.

My ohmeter maxes out at 2Amps current test, will that be sufficient to put in series for tests twixt the telco’s NI and my 2 phones for testing ? I’m not aware of the exact # of milliamps so I haven’t done the math… last time I went a measly amp over my entire meter bit the dust instead of the 2A fuse blowing. shrug.

Everything else about asterisk is working wonderfully and I truly love it and plan to pepper it about clients all over the U.S. Still, WTF is up with this phone ?? (rhetorical).

Any other input sincerely appreciated…


#5

In recent days, I’ve started playing in the Zaptel driver code, at least in the FreeBSD versions. I have seen mention to settings that can be tweaked, things like hook voltage. I don’t recall seeing a ring voltage, but that doesn’t mean it’s not in there. Maybe that is your best bet.

Alternatively, and I know it sucks to spend another $60, but you might look into an ATA and running SIP to that phone.


#6

I think you’re right on all counts. Either fidget or change protocols… Rarrrrrrrrr.
You know, I’ve always wanted to find a reason for that 9000$ spectrum analyzer/ohmeter on roids at Fry’s Electronics :smile: I bet that could reverse engineer this problem with the quickness… fidget with the source until the FXS signal topo looks close enough on the major boundaries to the NI signal topo to work… yeah right, like I can afford 9 large for a meter. LOL. BUT IF I COULD… I would certainly use it to solve this problem :smiley:
Though I DO have a VERY basic oscilloscope, I wonder if one vieweable axis + twiddling + record-keeping would work…I doubt I even have the correct probe spec… damn i really need to sleep now.

Thanks again for all the help guys!

More later after REM sleep and more hacking…


#7

Found this thread earlier on google, not sure how relevant this is to my and similar situations, but there is reference to RING_OSC which seems to translate to something relating to ring voltage oscillation frequencies, as the measurements for RING_OSC in wctdm.c are measured in Hz. There is a reference link in this post to specs relating to the setting (which i haven’t even clicked, let alone skimmed or read), but the main difference here is that this entire thread is pertaining to ringer settings in other countries… NOT intra-specification nuances. (U.S., in my case). Still, could very well lead somewhere… I don’t want to blow up the tdm400 board as my primary concern.
I don’t claim to know a damn thing about ringer oscillation freqs but i’m willing to learn to get my damn phone to ring!

Check it:
copilotconsulting.com/mail-a … 15191.html

SLEEP. For real now. Really.
Peace :smile:

Jayson


#8

Is it possible that TDM400 component tolerances, (crystal, transistor, etc.) vs. expensive CO channel-bank component tolerances are creating the fertile ground in which uncovered variants means certain phones won’t ring ? If the mean tolerances affecting the oscillation on the TDM400 are (rhetorically) +3%, and those on the CO channel banks are + .5%, perhaps this is the narrow sliver in which finicky phones don’t ring ?

As long as someone can theorize that it’s safe to compile wctdm.ko with RING_OSC equalling 18-22 Hz. stepping .5 Hz at a time, (by figuring out the appropriate HEX value for each step) then this is the first troubleshooting approach i’m going to take.

I am clueless when it comes to electronic engineering, so i’m hoping someone can shed some light on this ring_osc thing and the possibility of wider tolerances on a tdm400 createing narrow uncovered bands in which a few phones operate… and IF IT’S SAFE to twiddle on my tdm400 18-22Hz, stepping .5 Hz ?

zzzzzzzzzzzz