My analog phones do not sound


#1

Hello,

I have a tdm400p with two fxs modules and two fxo modules.
It is working well but my analog phones don’t make any sounds when they ring (and I can answer a phone call).

My zaptel.conf:
loadzone = fr
defaultzone = fr

fxsks = 1-2
fxoks = 3-4

My zapata.conf:
[channels]

language = fr
nationalprefix = 0
internationalprefix = 00
usecallingpres = yes

echocancel = yes
echocancelwhenbridged = yes
echotraining = yes

overlapdial = yes
immediate = no

rxgain=0.0
txgain=0.0

;;;[LIVEBOX]
signalling=fxs_ks
context=from-livebox
channel => 1

;;;[PSTN]
signalling=fxs_ks
context=from-pstn
channel => 2

;;;[INTERNE]
signalling=fxo_ks
context=from-internal
channel => 3-4

My extensions.conf:
[from-internal]
exten => _X.,1,Dial(ZAP/1/${EXTEN})

[from-livebox]
;exten => s,1,Dial(SIP/123) ;;;;Works well
exten => s,1,Dial(ZAP/3);;Works but the phone doesn’t ring

Any help would really be appreciated.
Regards.


#2

i’m not familiar with FXS modules on the TDM400 cards, but the first thing that came to mind was whether you have connected the molex power connector on the card ? i understand that’s required to generate ringing voltages.

also, are you loading your wctdm with your country code ? e.g. opermode=FRANCE


#3

Thanks for your fast reply,

I have connected my power-supply cable on the rear of my card.
But I don’t think that I’m loading my wctdm with my country code.
I think I have to add it in the modprobe.conf file, is it?

Regards.


#4

yes, it depends on the OS you’re running. i’m using an FC2-based distro and my /etc/modprobe.conf file contains this line


#5

I’ve tried to put ‘opermode=FRANCE’ but It doesn’t work…

My phones doesn’t ring and when I do a ‘dmesg’ it’s say to me “wcfxo: ‘FRANCE’ invalid for parameter ‘opermode’”

Any idea?


#6

what build are you using ?

can you look in the source for wcfxo, the parameters should all be listed in there. usually /usr/src/zaptel/wcfxo.h i think !


#7

I use an Asterisk 1.2.1 built on a i686 running Linux Kernel 2.6 on Centos.

I’ve tried to look in source code and I find this:


static int opermode = 0;
******************and
fxo_modes[] =
{
{ “FCC”, 0, 0, 2, 0, 0, 0, 0 }, /
US /
{ “CTR21”, 0, 0, 3, 0, 0, 3, 0 }, /
Austria, Belgium, Denmark, Finland, France, Germany,
Greece, Iceland, Ireland, Italy, Luxembourg, Netherlands,
Norway, Portugal, Spain, Sweden, Switzerland, and UK */
};


What do you think about it?
(it seems I have to change the fxo mode to ctr21, but how???)


#8

i’ve just had a look at 1.0.10 source (can’t get access to 1.2.1 right now, but it’s similar enough i think)

isn’t the wcfxo module for the X100P cards ? shouldn’t you be loading wcfxs instead ? apologies if i’m mislead you on this point !!


#9

It seems it’s the parameters of the wctdm module I have to modify.
I’ll try to and hop it will works…


#10

I’ve tried again to put the parameters in my ‘modprobe.conf’ and I don’t have any error more…

I put:
options wctdm opermode=FRANCE fxshonormode=1 boostringer=1

The ‘dmesg’ cmd shows that this parameters are applied:
Module 0: Installed – AUTO FXO (FRANCE mode)

But my phones doesn’t ring…

Does someone have any idea?


#11

Some news:

I tried with an other phone and it’s seems to work (the new phone is
ringing…).
(I have to load the module with modprobe -vv wctdm boostringer=1).
I will search why the others doesn’t…

An other question comes to me:
I have this context: External call to Asterisk box and TDM400p
when I hang up the phone (on external line), the phones (on the internal
side) continue to sound.
It seems that the system doesn’t see that I hang up.
Any idea on this new problem?

Regards,
Cordialement.


#12

according to your first post, you’re using kewlstart. you could try adding hanguponpolarityswitch=yes to your zapata.conf and testing.

bear in mind that you should check with your telco to establish whether they send a polarity reversal for anything else … if they do you’ll get false hangups.

have a look at the wiki on voip-info.org, search for zapata.conf and explore the options you have detailed there.


#13

Thanks for reply baconbuttie,

It seems to work!
I’ve add hanguponpolarityswitch=yes and busydetect=yes.
(I did not know this option ‘hanguponpolarityswitch’ and I recommand you this link:http://www.asteriskguru.com/tutorials/resolving_hangup_detection_problems_fxo_tdm_voicemail.html).

Regards,
Cordialement.