Stuck Channels - group show channels

This is about Stuck or Non Active calls when running command “group show channels”.

I use group channel details to control a number of things on my asterisk servers.

I am finding as server load increases this becomes a problem in that channels are staying in the “group show channels” list that are actually not active anymore.

Is their some way to clear out the non active channels? Or to make them close correctly.

This is becoming such a problem that I am some times having to run “channel request hangup all” to clean up the list, it takes a while but at least it does not require me doing a asterisk restart. It does however kill all active calls and hangup the calls which people are talking on so it is by far not ideal way to fix the problem.

Any ideas what I can do or how to stop this happening?

Why are the channels not hanging up. That could be a bug in Asterisk or a misunderstanding about how your particular channel technology works. You will need to provide stand debugging logs and also core show channels output.

I am noticing a similar thing at a couple of my servers. Some don’t have this problem, but some do.

What version of Asterisk are you running?

What version of Asterisk are you running?[/quote]

I am running Asterisk

What does trigger this more then normal is when server load spikes. It only needs to spike for 30 seconds and it will then cause a snow ball affect that slows down or stops channels removing them self from the list. I had one server today go over 1,000 listed channels open when no way would that be possible as at any time there was not even 50 active calls.

Did you try testing with Asterisk 11 or Asterisk 12?

Perhaps this is just a feeling, but I think I am not seeing my problems on Asterisk 11 with which I upgraded my Asterisk 1.8 box that was giving me the problems.

Thanks for that info. I will try Asterisk 11 or 12. Do you suggest 11 over 12 for any reason or that is just what you have tried. I honestly have not even installed 11 or 12 I assume it is the same as 1.8 I will give it a try. Do let me know if you are finding 11 better then 12 though so I will stick with 11 if you are finding it better.

The one thing Asterisk 11 has over Asterisk 12 is that Asterisk is LTS - Long Term Support. That is why I chose Aserisk 11. I did not test Asterisk 12.

As of upgrading Asterisk 1.8 to Asterisk 11 I seem to remember 2 things I needed to do diferently:

  • AstDB software has changed
  • RTP module needs an additional library

Take notice in “make menuconfig” part of the installation and check all the main modules. You will figure it out quickly :wink:

Thanks for the pointers. I have got Asterisk 11 installed. Having some problems with g729 codec though, did you run into this problem at all?

My server CPU is: Intel Xeon E3-1225v2
I have another server with similar CPU: Core™2 Quad Q6600 / Xeon X3220 and this is running fine with - Asterisk 1.8
So I tried same type for Asterisk 11: no luck with it working though, tried a few others also no luck with them either.

Do you need to turn on g729 for Asterisk 11? A my old installs I never turned anything on just loaded the codec files, and it worked.

I am not using g729, so I really can’t say. Sorry.