Strange Snom "Retrieve" button behavior

On some of the phones, hitting the “Retrieve” button when there is no message does nothing. I’m fine with that.

On the other phones it calls extension 109.

I have no idea how to address that.

Ive set up an “asterisk” extension in my user’s context, and evewrything works fine when there actually is a voicemail.


im kinda hoping this is the first time someone actually answers a question of mine on this forum. or at least tries.


when i was a newb i found the freenode channel very helpful. Since then it seems like if I have a question beyond “how do restart the server gracefully” i cant get any help.

anyone else noticing this? ive tried the mailing list, with its 100 messages per day, and I seem to get the same result: i’m basically totally on my own here. there is no real community support to speak of.

Copies of logs, copies of contexts, version of Snom firmware, phone model. errors etc etc would help us in helping you.

ah, as i recall Snom phones by default look for their vm exten in sip headers. Try adding vmexten=yourvoicemailexten to the phone’s entry in sip.conf.

Alternatively, reconfigure the button to be just a speed dial for the voicemail exten. that usually works :smiley:

(at least i tried… let me know if the vmexten thing works)