Strange MWI behaviour

Hi all,
as per issues.asterisk.org/view.php?id=18762 I configured “unsolicited_mailbox”.

sip.conf

[Exchange]
host=10.9.101.161
type=friend
insecure=port,invite
transport=tcp
port=5065
context=from-internal
unsolicited_mailbox=@default

[3950]
deny=0.0.0.0/0.0.0.0
secret=lwsi3030
dtmfmode=rfc2833
canreinvite=yes
context=from-internal
host=dynamic
trustrpid=no
sendrpid=no
type=friend
nat=never
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/3950
mailbox=3950@default
permit=0.0.0.0/0.0.0.0
callerid=device <3950>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

but I am facing this issue:

whatever I put on sip.conf at “unsolicited_mailbox” and “mailbox=3950@default” ,when I receivce a NOTIFY msg from exchange, notification are always stored as below:

Event: MWI
Mailbox: @default
Context: SIP_Remote
NewMessages: 32
OldMessages: 1
EntityID: 00:50:56:af:00:54

What Am I wrong?

It does not look like your Exchange box knows what extension the voicemail is being left for.

Can you leave VM for specific users in Exchange by dialing it directly from Asterisk and adding the necessary Diversion header?

[quote=“penguinpbx”]It does not look like your Exchange box knows what extension the voicemail is being left for.

Can you leave VM for specific users in Exchange by dialing it directly from Asterisk and adding the necessary Diversion header?[/quote]

Sure I can!! Below the NOTFY message sent by Exchange to Asterisk:

<— SIP read from TCP:10.9.101.161:44326 —>
NOTIFY sip:3950@172.16.52.123:5060;user=phone SIP/2.0
FROM: sip:3950@172.16.52.123:5060;user=phone;epid=D9EC218ACB;tag=7d71ea6f93
TO: sip:3950@172.16.52.123:5060;user=phone
CSEQ: 4 NOTIFY
CALL-ID: a7d2277ef2db44fab721f2582fe91005
MAX-FORWARDS: 70
VIA: SIP/2.0/TCP 10.9.101.161:44326;branch=z9hG4bKa56fabd0
CONTACT: sip:3950@172.16.52.123:5060;user=phone
CONTENT-LENGTH: 101
EVENT: message-summary
SUBSCRIPTION-STATE: terminated
USER-AGENT: RTCC/3.5.0.0 MSExchangeUM/14.01.0323.000
CONTENT-TYPE: application/simple-message-summary

Messages-Waiting: yes
Message-Account: sip:3950@172.16.52.123:5060;user=phone
Voice-Message: 35/1
<------------->
— (13 headers 3 lines) —

<— Transmitting (no NAT) to 10.9.101.161:44326 —>
SIP/2.0 200 OK
Via: SIP/2.0/TCP 10.9.101.161:44326;branch=z9hG4bKa56fabd0;received=10.9.101.161
From: sip:3950@172.16.52.123:5060;user=phone;epid=D9EC218ACB;tag=7d71ea6f93
To: sip:3950@172.16.52.123:5060;user=phone;tag=as7b549346
Call-ID: a7d2277ef2db44fab721f2582fe91005
CSeq: 4 NOTIFY
Server: FPBX-2.9.0(1.8.4.4)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Length: 0

Ideas???

Try shortening the mailbox line in sip.conf from:

mailbox=3950@default

to:

mailbox=3950

You might also try removing other parameters from the peer, adding them back, one by one, starting with the mailbox.

[quote=“penguinpbx”]Try shortening the mailbox line in sip.conf from:

mailbox=3950@default

to:

mailbox=3950

You might also try removing other parameters from the peer, adding them back, one by one, starting with the mailbox.[/quote]

I had already tried… but nothing is changed.
Do you have it working?