Asterisk MWI issue


I am using Asterisk personally at home.
My SIP client (SPA 3000) supports MWI with SIP NOTIFY messages.
With a previous version of Asterisk I had no problems with MWI. But now I am using the following version which comes with Trixbox, and I have problems with MWI.


Problem description:
When a voicemail is left on the extension, a SIP NOTIFY message is sent to my SIP client and the MWI is received ok. This is good.
But when I delete all Voicemail through AMPortal, SIP NOTIFY message notifying that there is no voicemail left is not sent to the client.
Normally , I expect to receie a SIP NOTIFY message as soon as my inbox is empty.
However, this does not happen when I delete voicemail through GUI.
If I delete voicemail through phone, I receive the SIP NOTIFY message.

How can I fix this problem ?
Is this a misconfiguration or a bug ? If it is a bug, is there any fix for it ?


Sounds like a missing feature rather than a bug. AMPortal needs to notify asterisk that voicemail has been fiddled with.
You’re probably SOL unless they add that in the future, maybe add it to their bug tracker?

What do you mean by “SOL” ?
this is not a new feature. it was working with previous version of Trixbox which uses Asterisk 1.4.x.

So, do you think it is a problem of AMPortal rather than Asterisk ?
If so, maybe I should look for a fix on AMPortal
Could I solve it by updating AMPortal ? (where can I find AMPortal updates ?)

On the other hand, I still think that may be Asterisk is the problem. Maybe it does receive the update from AMPortal but does not create a SIP NOTIFY to the client…
How can I be sure ?

I’d appreciate any reply. Because I still couldn’t find a solution.

At the risk of Ian’s wrath, I’ll point out that very few people here know anything about Trixbox. You would almost certainly be better off using their official channels, although a quick Google will find you some free peer support forums for it.


what you need to do is leave a message for a handset, then open 2 ssh termina;s and in one run asterisk with “sip debug peer xxxx” where xxxx is the extension. Then in the other go to the relevant voicemail INBOX doing a ls should show 2 or more files
msg0000.gsm msg0000.txt msg0000.wav

now do a rm msg* and watch the screen with the sip debug and you should see something like below.

if you dont then it looks like a asterisk bug to me. all the gui does is read the directory and respond accordingly

for example if the dir had

-rwxr-xr-x 1 asterisk asterisk 10065 Sep 14 14:12 msg0000.gsm
-rw-r–r-- 1 asterisk asterisk 255 Sep 14 14:12 msg0000.txt
-rwxr-xr-x 1 asterisk asterisk 97644 Sep 14 14:12 msg0000.wav
-rwxr-xr-x 1 asterisk asterisk 10626 Sep 14 14:16 msg0001.gsm
-rw-r–r-- 1 asterisk asterisk 255 Sep 14 14:16 msg0001.txt
-rwxr-xr-x 1 asterisk asterisk 103084 Sep 14 14:16 msg0001.wav

my mwi says I have 2 messages if I delete all the msg0001 files it then reports I have one as expected

If you have fop enabled what does that say ?


Hi Ian,

Thanks for your reply.
In fact, I had tried it several times before, but I just tried once more for you.

The FOP gets updated when I delete the msg* files from ssh session, but no SIP NOTIFY is sent to the extension. (I checked as you suggested on the console)

Also, if I delete the message from GUI, then the FOP gets updated faster (I guess GUI triggers it as soon as I delete it)

What do you say ? is it an Asterisk bug or an AMPortal bug ?



OK this is an Asterisk problem, Now whats causing it ?

im guessing that the setting pollmailboxes=yes is not set as it seems this is needed for asterisk 1.6 and

Try these and see if it works.

pollmailboxes=yes or no>


I have the line “pollmailboxes=yes” in voicemail.conf (I have added that with a suggestion)
but it does not work.
what else ?

do you have the pollfreq set ?

NO; I don’t have pollfreq in the conf.
What value do you want me to test ?


30 will mean its polls every 30 secs


ok ; I’ll try now and inform.

I set it ; left a vm. then I deleted the vm from GUI.
sip notify is not sent.

when I delete the vm from phone (by calling inbox) I receive the sip notify as soon as I hang up.


I know you have set it can you do a “restart now” at the asterisk cli.

Also can you do as I said erlier, not using a gui to delete the message but doing it manually by deleting the files and capturig the out put, and remeber the poll frequency so you will have to wait 30 seconds.

So to recap

leave a message

check the message directory to check what files are there.

Delete them

WHile on a second ssh console have a sip trace running on that peer


just did as you’ve suggested. no sip NOTIFY message.

I only see OPTIONS and REGISTER messages between Asterisk and the SIP client.
No SIP notify message to clear the MWI.


Taken from the upgrade notes

[quote]If you use any interface for modifying voicemail aside from the built in
dialplan applications, then the option “pollmailboxes” must be set in
voicemail.conf for message waiting indication (MWI) to work properly. This
is because Voicemail notification is now event based instead of polling
based. The channel drivers are no longer responsible for constantly manually
checking mailboxes for changes so that they can send MWI information to users.
Examples of situations that would require this option are web interfaces to
voicemail or an email client in the case of using IMAP storage.Applications[/quote]

and from the samples for

[quote];pollmailboxes=no ; If mailboxes are changed anywhere outside of app_voicemail,
; ; then this option must be enabled for MWI to work. This
; ; enables polling mailboxes for changes. Normally, it will
; ; expect that changes are only made when someone called in
; ; to one of the voicemail applications.
; ; Examples of situations that would require this option are
; ; web interfaces to voicemail or an email client in the case
; ; of using IMAP storage.
;pollfreq=30 ; If the “pollmailboxes” option is enabled, this option
; ; sets the polling frequency. The default is once every
; ; 30 seconds.[/quote]

If its not working I would check the bug tracker and raise a bug if its not mentioned


where is the bug tracker ?

which bug tracker should I use ? where is it please ?

where is the bug tracker that is responsible for this kind of issues ?