Still cant get asterisk to answer pstn


#1

ok, ive completely run out of ideas, trying to get asterisk to work for about 3 days of random config changes, ideas, net searching and recompiling. and im almost totally hacked off with the whole idea.

im hoping someone can give me a clue.

i have a mini itx board (via mii6000 eden). im booting slackware from flash (kernel 2.6.12.2). i have a tdm400p card with 1 FXO and 1 FXS. i have zaptel 1.2 and asterisk 1.2. they both compiled fine no problems.

im trying to set up the minimal config that actually answers the pstn (in the uk). so zaptel.conf has

loadzone=uk
defaultzone=uk
fxoks=1
fxsks=2

then i have zapata.conf as:

[channels]
context=incoming
signalling=fxs_ks
usecallerid=no
channel => 2

and finally extensions.conf looks like:

[incoming]
exten => s,1,Answer()
exten => s,2,Echo()

when i call it, i get this:

Executing Answer(“Zap/2-1”, “”) …
Executing Echo(“Zap/2-1”, “”) …
WARNING: chan_zap.c:3904 zt_handle_event: Ring/Off-hook in strange state 6 on channel 2.

if i dont have the “usecallerid=no” i get a bunch of different messages relating to callerid failure (there’s none on this line). the answer never happens, the caller is never answered. also, from reading the code, strange state 6 appears to be AST_STATE_UP whether that helps i dont know.

ive tried other stuff like setting busydetect=no, callprogrss=no but nothing changes it.

thanks for any clues/.


#2

It looks good to me.

The only other things I can think of are trying
immediate=yes
in zapata.conf, and maybe trying the other signalling methods.

I’ve gotten this Ring/Off-Hook in strange state message. I get it consistently if I try to dial out on another extension hanging of the same PSTN line that’s coming into the zap card. It’s as if Asterisk is confused by the DTMF and/or ringing on the outgoing call.


#3

Are you able to make outgoing phone calls through the FXO interface?

Is everything plugged into the correct port (don’t laugh but I had some really frustrating problems until I realized I had connected my phone line to the wrong port.)

You may be able to get some help calling Digium’s support line. I’ve found them to be very helpful.


#4

It sounds like the old cable problem again. Make sure you’re using a modem cable not a phone cable

rgds


#5

hi guys, thanks for the replies.

middletn, you are a genius. i had deliberately used a phone cable, but now i think of it, that’s wrong. i switched to a modem cable and it picks up ok. the warning message has also gone.

maybe they should put this in the FAQ in large letters: do not use a phone cable.

thanks again,


#6

Shoot. What the heck is a modem cable? I always thought they were the same thing!

As I mentioned, I get these “strange state” messages sometimes too. Wondering if it’s my cable?


#7

does anybody know what the color / wire scheme is for a modem cable, or where you could buy one at?


#8

In the UK, phone and modem cables are wired differently. A modem cable as I undertand it is a US phone cable. (stand to be corrected on this one)


#9

I had that problem when i was using cable with 4 gold pins on. I replaced it with a cable with just 2 pins and it answered perfectly :open_mouth:.