Starting with Asterisk

I’m a pretty newbie in Asterisk but I have been following this forum on a daily basis.
I bought the Asterisk - The Definitive Guide and try to learn the more as I can and reading all Asterisk wiki.
Now, running Asterisk 13.17.2 on VM Virtual Box - CentOS 7 Minimal Install, I try to follow the instructions on and register a Zoiper in my iPhone.
I ran ‘make samples’ and configured extensions.conf and pjsip.conf as requested but I couldn’t register. My host computer and VM Virtual Box Box have different IP’s that I supposed to be okay. I’m using the VM Virtual Box IP as a domain IP on Zoiper. I sent a ping from my iPhone to this IP and it’s Okay but I still not able to register Zoiper.
I’m still little confused with all those commands I trying to understand which of those could I use to tracking the problem.

Have you disabled the OS firewall, at least selectively?

Hello, David
You’re right. I disabled the CentOS firewall for a while and I could register. Let me try to set some rules to that and see what happens.
Thank you!